Ticket #258 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Generic Single Instance Functionality

Reported by: mickey@… Owned by: stefan@…
Priority: normal Milestone:
Component: openmoko-libs Version: unspecified
Severity: major Keywords:
Cc: buglog@…, kresp0@…, giles.jones@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

It is not advisable to implement this in every application. See
http://log.emmanuelebassi.net/archives/2006/10/love-and-communication/

Change History

comment:1 Changed 12 years ago by alphaone@…

  • blocked set to 341

For this the gtkunique library needs to be integrated in mainmenu
gtkunique was developed for gtk+ 2.10, so we might need to backport it.

comment:2 Changed 12 years ago by mickey@…

  • Owner changed from cj_steven@… to stefan@…

Stefan Schmidt will take care about a) backporting and b) integrating it into
main menu.

comment:3 Changed 12 years ago by elrond+bugzilla.openmoko.org@…

  • Priority changed from high to normal
  • Component changed from openmoko-mainmenu to openmoko-libs
  • Summary changed from Main Menu needs to have Single Instance functionality to Generic Single Instance Functionality
  • I guess, this bug does not anymore affect main menu, as it is now in the panel plugin.

BUT:

  • This whole thing still applies on a more generic level (dialer comes to mind very quickly)

So I'm:

  • Retitling
  • Re-Assigning to openmoko-libs component, which seems to be the second best fit for "framework global".
  • Changed Priority from P2 to P3: We can live without single instance for a while

comment:4 Changed 12 years ago by stefan@…

  • Cc kresp0@… added

comment:5 Changed 12 years ago by stefan@…

* Bug 728 has been marked as a duplicate of this bug. *

comment:6 Changed 12 years ago by stefan@…

  • Cc giles.jones@… added

* Bug 717 has been marked as a duplicate of this bug. *

comment:7 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

It's now implemented as part of the matchbox libraries today uses -- therefore
closing this here.

Note: See TracTickets for help on using tickets.