Ticket #259 (closed defect: community)

Opened 12 years ago

Last modified 11 years ago

implement 500mA charging in u-boot using wall-outlet charger

Reported by: laforge@… Owned by: laforge@…
Priority: high Milestone:
Component: u-boot Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, werner@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description (last modified by roh) (diff)

u-boot should export two USB configuration descriptors that are completely
identical, with one difference: power consumption. The first config descriptor
should indicate 250 units (500mA), whereas the second one should indicate 50
units (100mA).

Please also note that we should remove the 'self powered' flag in both
descriptors, too.

Change History

comment:1 Changed 12 years ago by laforge@…

This has now been implemented as part of svn commit 1364. However, this code
needs some more cleanup, namely

  • decouple the raw pcf50606 calls from usbtty into some kind of per-machine

abstraction

  • make sure this also works with gserial, not only cdc_acm

Also still missing is the timer code, i.e. just heuristically guess that the ac
wall outlet is plugged in (and switch to 500mA) if we get CHGINS but never see a
USB bus reset following it within 30 seconds.

comment:2 Changed 12 years ago by laforge@…

  • Summary changed from implement 500mA charging in u-boot to implement 500mA charging in u-boot using wall-outlet charger

renaming to reflect that this is only about the wall-outlet charger

comment:3 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to wontfix

We don't ship a wall-outlet charger. Closing as WONTFIX.

comment:4 Changed 11 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution wontfix deleted

we need this for GTA02!

comment:5 Changed 11 years ago by mickey@…

Will we ship a charger for GTA02?

comment:6 Changed 11 years ago by willie_chen@…

  • Status changed from reopened to new
  • Owner changed from stefan@… to willie_chen@…

comment:7 Changed 11 years ago by willie_chen@…

  • Status changed from new to closed
  • Resolution set to wontfix

That's not blocker.

comment:8 Changed 11 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution wontfix deleted

so what? Bugzilla documents all known bugs, not only blocker bugs. If it's not
a blocker item, then don't give it blocker priority.

As long as this bug is not fixed, it should remain in bugzilla.

comment:9 Changed 11 years ago by andy@…

  • Owner changed from willie_chen@… to laforge@…
  • Status changed from reopened to new

Yes, good point Harald.

Reassigning this and the other ones we closed out yesterday to Harald since we
won't do anything on it until the existential crisis of reaching 1.0 is over,
but Harald feels strongly it should not be closed.

comment:10 Changed 11 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

Closing it again, works in GTA02 U-Boot, nobody took care about any possible GTA01 issue for 7 months.

comment:11 Changed 11 years ago by roh

  • Status changed from closed to reopened
  • Resolution fixed deleted
  • Description modified (diff)

comment:12 Changed 11 years ago by roh

  • Status changed from reopened to closed
  • Resolution set to community
Note: See TracTickets for help on using tickets.