Ticket #261 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Implement 500mA charging using wall-outlet charger

Reported by: laforge@… Owned by: laforge@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, werner@…, eric_liu1@…, cesarb@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Currently the Neo1973 only charges with 500mA if we're attached to a real USB
host, and only after that host has issued SET_CONFIGURATION on our configuration
indicating 500mA power consumption. This is how the USB specification asks for
it to be implemented.

However, since the charger doesn't have a built-in USB host, we need to
implement some heuristics, i.e. if we detect charger presence (EXTON or better:
CHGINS interrupt, we start a timer. If we do not receive a USB bus reset or any
USB packets during 30 seconds, we assume to be connected to the wall charger and

This can be further improved by checking for charger errors, and if we get an
error while being in the 'wall outlet charger heuristically detected' mode, we
can disable fast charging again.

Please note that GTA01Bv4 hardware has a different solution to this problem.

Change History

comment:1 Changed 12 years ago by stefan@…

Is this bug still valid or is the decision to throw away the broken wall charger?

comment:2 Changed 12 years ago by laforge@…

I'd still want to implement this heuristic mode. And even for GTA01Bv4, we need
code in the PCF50606 driver supporting the accessory detection unit to support
the new charger.

comment:3 Changed 12 years ago by stefan@…

OK. IIRC the charger for GTA01Bv4 has a circuit to handle the USB handshake.
Means we don't have to break USB specs and the detection and handling should far
easier.

comment:4 Changed 12 years ago by laforge@…

  • Cc eric_liu1@… added

* Bug 429 has been marked as a duplicate of this bug. *

comment:5 Changed 12 years ago by cesarb@…

  • Cc cesarb@… added

See also #685

comment:6 Changed 12 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to wontfix

We don't ship a wall-outlet charger. Closing as WONTFIX now.

comment:7 Changed 12 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution wontfix deleted

hey, we need to implement this for GTA02. don't close those bugs!

comment:8 Changed 11 years ago by mickey@…

Will we ship a charger with GTA02?

comment:9 Changed 11 years ago by willie_chen@…

  • Status changed from reopened to new
  • Owner changed from stefan@… to willie_chen@…

comment:10 Changed 11 years ago by willie_chen@…

  • Status changed from new to closed
  • Resolution set to wontfix

That's not blocker.

comment:11 Changed 11 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution wontfix deleted

so what? Bugzilla documents all known bugs, not only blocker bugs. If it's not
a blocker item, then don't give it blocker priority.

As long as this bug is not fixed, it should remain in bugzilla.

comment:12 Changed 11 years ago by andy@…

  • Owner changed from willie_chen@… to laforge@…
  • Status changed from reopened to new

comment:13 Changed 11 years ago by andy

  • Status changed from new to closed
  • Resolution set to fixed

This is solved for GTA02, pcf50633.c does the proper business with 100mA / 500mA and 1A charging limits depending on charger type plugged in (via USB ID) and the USB stack callback about enumeration.

Note: See TracTickets for help on using tickets.