Ticket #293 (closed enhancement: worksforme)

Opened 12 years ago

Last modified 11 years ago

don't boot kernel if switched off and charger inserted

Reported by: mickey@… Owned by: laforge@…
Priority: high Milestone:
Component: u-boot Version: unspecified
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

If USB is not connected, the device doesn't (fully) turn on and boot. This
problem only occurs when USB is connected.

Change History

comment:1 Changed 12 years ago by laforge@…

So you state that currently:
1) No USB connected: Device does not turn on if battery inserted
2) USB connected: Device does turn on if battery instarted

Which is exactly how the PMU is designed. Basically it detects a 'charger
insertion' (USB connected) and wants to signal that to the CPU at the soonest
possible point in time - which is once you insert the battery.

What is the desired behaviour? Maybe you can describe this more verbosely, so I
can check if the hardware supports what you want or not.

comment:2 Changed 12 years ago by stefan@…

Mickey, are you fine with the behaviour after explanation?

If yes, please mark as fixed, if not please explain. Thanks.

comment:3 Changed 12 years ago by mickey@…

I'd find it more convenient if it would turn on when you insert the charger, but
turn off immediately after negotiating 500mA, i.e. it only should start to boot
the kernel when I hold the power button.

comment:4 Changed 12 years ago by laforge@…

  • Owner changed from laforge@… to werner@…
  • Severity changed from normal to enhancement
  • Summary changed from Device automatically turns on and boots when inserting battery & USB connected to don't boot kernel if switched off and charger inserted

renaming and marking it as enhancement

comment:5 Changed 11 years ago by willie_chen@…

  • Owner changed from werner@… to willie_chen@…

comment:6 Changed 11 years ago by willie_chen@…

  • Status changed from new to closed
  • Resolution set to later

This isn't block.

comment:7 Changed 11 years ago by laforge@…

  • Status changed from closed to reopened
  • Resolution later deleted

I'm reopening this since it already was marked as 'enhancement'. This clearly
indicates that it isn't a blocker item at all.

comment:8 Changed 11 years ago by andy@…

  • Status changed from reopened to new
  • Owner changed from willie_chen@… to laforge@…

comment:9 Changed 11 years ago by andy

  • Status changed from new to closed
  • Resolution set to worksforme

GTA02 does turn on and boot with USB insertion, which is desired behaviour now there is needed a "charging indication" action when it is charging. So closing as worksforme.

Note: See TracTickets for help on using tickets.