Ticket #300 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Mechanical quality of Power button and AUX button

Reported by: hrw@… Owned by: tony_tu@…
Priority: high Milestone:
Component: Core System Version: GTA01Bv3
Severity: major Keywords:
Cc: laforge@…, sean_mosko@…, buglog@…, bluelightning@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Neo1973 power button is too deep in case for me. I have big fingers and to start
gta-01 I have to press button for few seconds. Recently I switched to starting
phone using stylus because with USB cable attached it is too hard to press power.

Change History

comment:1 Changed 12 years ago by mickey@…

  • Summary changed from Power button is too deep in case to Mechanical quality of Power button and AUX button

I agree and I have modified this to cover the AUX button as well, I have a hard
time pressing these buttons in a controlled manner. The tactical feedback is
very low. Perhaps they should use microswitches (with that cool click clack
sound...)

comment:2 Changed 12 years ago by alphaone@…

While the power button works fine for me I also have problems with the AUX button.
It is quite hard to press it all the way and it is not always pressed when you
have it pushed in.
What I mean is there is that tactile feedback when you press the button (klick),
but you have to press it slightly harder than that to actually cause a button
press event.

comment:3 Changed 12 years ago by laforge@…

Those are actually two separate issues:

1) the button itself (the device soldered on the PCB) was not able to cope with
the reflow soldering temperature profile used by FIC - despite claims of the
manufacturer. GTA01Bv4 will use higher quality buttons

2) apparently, for completely unknown reasons, somebody very early in the
project wrote a mechanical spec that said "the second button must be protected
against accidental button presses". Until I managed to dig this out last week,
nobody seemed to remember this :(

Since this is now known, I'm sure new plastic buttons will be produced shortly
to fix this. Not sure if it will be before GTA01Bv4, though :(

comment:4 Changed 12 years ago by laforge@…

  • Owner changed from sean_chiang@… to tony_tu@…

reassigning this to tony.

tony: until when can we have better "aux" button plastic?

comment:5 Changed 12 years ago by laforge@…

  • Cc laforge@… added

comment:6 Changed 12 years ago by tony_tu@…

  • Status changed from new to assigned

We will use panasonic ones in GTA01Bv4, should be no problem this time

comment:7 Changed 12 years ago by laforge@…

  • Cc sean_mosko@… added

tony, I know the actual switches on the PCB will be panasonic.

However, I was talking about the plastic piece, part of the housing assembly.
Tim told me that the reason why it is so hard to press, is because it was
originally designed as emergency button, something that is supposed to be
difficult to press.

This is completely bogus, since we always intended it to be the dialer button.

comment:8 Changed 12 years ago by tony_tu@…

We might need chnage the material for better press/feel, see if we could
change it on later version.

We will discuss with mechanical to solve this issue. So you think the aux
button should be higher from surface 1mm or something?

comment:9 Changed 12 years ago by laforge@…

I think it should be on even surface with the housing when in un-pressed state.

Currently, when the button is not pressed, it is already slightly indented into
the case. Pressing it requires even more indentation into the case.

I think there should be a flat/even surface. It is just too hard to press
currently.

In any case, we should probably wait for the new panasonic switches to verify
their behaviour is not any different from the old switches. Once this is
verified, design/order the new plastic piece.

Please also note that for GTA02 we will need translucent plastic with a light
guide, coordinate with Tim on this.

comment:10 Changed 12 years ago by laforge@…

  • Cc bluelightning@… added

* Bug 257 has been marked as a duplicate of this bug. *

comment:11 Changed 12 years ago by alphaone@…

Tony, any news on this?

comment:12 Changed 11 years ago by wolfgang@…

  • Status changed from assigned to closed
  • Resolution set to fixed

FIXED

Note: See TracTickets for help on using tickets.