Ticket #350 (closed defect: community)

Opened 10 years ago

Last modified 8 years ago

OpenMoko keyboard usability issues

Reported by: jluebbe@… Owned by: michael
Priority: high Milestone:
Component: openmoko-keyboard Version: unspecified
Severity: major Keywords:
Cc: mickey@…, buglog@…, davewu01@…, flerchjj@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

These are some issues that prevent proper usage.

  • Replace the mode keys 'A' and 'a' with (sticky) Shift and CapsLock? key.
  • The number mode should be 3x4 (like the numpad on a pc keyboard).
  • Add cursor keys where possible and reposition the backspace (del) key.

Attachments

moko_theme.css (5.2 KB) - added by flerchjj@… 10 years ago.
css theme formatting for xml key layout
keyboard_flerchjj.xml (8.8 KB) - added by flerchjj@… 10 years ago.
partially modified keyboard.xml for css theming concept
matchbox-keyboard-color-patches.tar.gz (3.1 KB) - added by thseiler@… 9 years ago.
adds simple color theme to svn matchobox-keyboard
04-popups.patch (8.3 KB) - added by thseiler@… 9 years ago.
code for popups
04-thumbmode.patch (12.2 KB) - added by thseiler@… 9 years ago.
same as previous 04-popup.patch but also fixes the keyboards statemachine
05-layouts.patch (3.5 KB) - added by thseiler@… 9 years ago.
change keyboard.xml files to take advantage of color and thumbmode

Change History

comment:1 Changed 10 years ago by jluebbe@…

  • blocked set to 341

comment:2 Changed 10 years ago by songcw@…

  • Cc davewu01@… added

Thanks for your useful suggestion, I will discuss those with our graphics
designers. If you have any other useful issues, please tell us.

comment:3 Changed 10 years ago by alphaone@…

The default keyboard should also have the most common punctuation, etc. keys.
I think keys like @,.+-!? should be included in the standard layout if there is
still room.
Where possible, please try to use default locations (like on qwerty keyboard).

comment:4 Changed 10 years ago by stefan@…

We should also evaluate if it fits our needs to use the standard matchbox
keyborard and just add special theming for it.

comment:5 Changed 10 years ago by laforge@…

  • Owner changed from songcw@… to stefan@…

stefan, does this evaluation fit in your or daniels' schedule? It's quite
embarrassing that we still have this unusable keyboard right now.

comment:6 Changed 10 years ago by alphaone@…

  • Owner changed from stefan@… to alphaone@…

I'm looking into it now.

comment:7 Changed 10 years ago by alphaone@…

  • Status changed from new to assigned

comment:8 Changed 10 years ago by flerchjj@…

  • Cc flerchjj@… added

What method is currently used to make the keyboard? If it's a compiled X or GTK
program this will not work well for graphic designers (I know my wife is one),
unless it loads a humanly readable file to determine the layout.

If you go with Matchbox, layouts are made with simple XML. XML is structured &
well understood by designers (or they have tools that do). A number of layouts
can be defined ( though currently only 1 is supported ) each with any number of
rows of keys, defining the keyboard from top to bottom.

If you go this route let me know. I'd be willing to create some of the layouts I
made for the wishlist (after I get matchbox-keyboard installed or script
something to test it in a browser).

comment:9 Changed 10 years ago by alphaone@…

openmoko-keyboard actually is a fork of matchbox-keyboard and there is no real
reason why we're maintaining a fork of our own. I'm working on pushing the
additions we made upstream so we can use matchbox-keyboard with a different layout.

Changed 10 years ago by flerchjj@…

css theme formatting for xml key layout

Changed 10 years ago by flerchjj@…

partially modified keyboard.xml for css theming concept

comment:10 Changed 9 years ago by olv@…

  • Owner changed from alphaone@… to michael@…
  • Status changed from assigned to new

comment:11 Changed 9 years ago by willie_chen@…

Is it resolved?

Changed 9 years ago by thseiler@…

adds simple color theme to svn matchobox-keyboard

comment:12 Changed 9 years ago by flerchjj@…

I just started working on a gtk based alternative to the current virtual
keyboard that I plan to call "gtKeypad". I thought this might add to visual
consistency across the entire desktop theme.

The xml file format for keypad layout is very similar to what already exists.
I'll post the code in its current state on OpenMokoProjects? soon after I get
approval for the project. It is very much a work in progress at this point &
I've only been working on it on my computer desktop. I don't plan on trying it
in qemu for the moko until all the required functionality and formating is complete.

Changed 9 years ago by thseiler@…

same as previous 04-popup.patch but also fixes the keyboards statemachine

comment:13 Changed 9 years ago by thseiler@…

  • attachments.isobsolete changed from 0 to 1

Changed 9 years ago by thseiler@…

change keyboard.xml files to take advantage of color and thumbmode

comment:14 Changed 9 years ago by roh

  • Owner changed from michael@… to michael

comment:15 Changed 9 years ago by kenrestivo

I am now using the ASU Qtopia keyboard with the Full-QWERTY option, and it solves all my problems and is very usable. I'd suggest just using ASU as a solution.

comment:16 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community

we got illume and qtopia keyboards now so I will leave this as 'community'

Note: See TracTickets for help on using tickets.