Ticket #385 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

libmokogsmd should restart gsmd if it went away during a session

Reported by: koen@… Owned by: mickey@…
Priority: high Milestone:
Component: openmoko-libs Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, jserv@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Openmoko dialer can't be used after gsmd has been restarted (e.g by a package
update). The user has to kill openmoko-dialer and/or X to get a working phone
GUI again. This is clearly unacceptable behaviour

Change History

comment:1 Changed 12 years ago by tonyguan@…

  • Status changed from new to assigned

Sure, I know this issue, but still waiting for some api from libgsmd to
determine the status of gsmd and modem.

comment:2 Changed 12 years ago by laforge@…

  • Owner changed from tonyguan@… to laforge@…
  • Status changed from assigned to new

comment:3 Changed 12 years ago by alex@…

Is it possible for libgsmd to have a kind of restart-upon-disconnection feature
? if the FD is closed because of a gsmd restart or crash, it should be possible
to re-issue the connection in a hidden way so the application do not have to be
restarted.
It is in fact the same for the panel-gsm applet. it should be good to re-connect
gsmd after it restarts or crash.

comment:4 Changed 12 years ago by koen@…

if libgsmd would use dbus-activation the problem would go away as well

comment:5 Changed 12 years ago by jserv@…

  • Cc jserv@… added

comment:6 Changed 12 years ago by thomas@…

  • Owner changed from laforge@… to mickey@…
  • Component changed from openmoko-dialer to openmoko-libs
  • Summary changed from Openmoko dialer fails after gsmd restart to libmokogsmd should restart gsmd if it went away during a session

This should probably now be solved in libmokogsmd. libmokogsmd already attempts
to start gsmd if it isn't running when the library is initialised. It should
probably attempt to start gsmd again if it dies during a session.

comment:7 Changed 11 years ago by tick@…

  • Status changed from new to closed
  • Resolution set to fixed

It does work.
But there are some side effects, and I think the better way is to start gsmd
well for the first time.
So that, the need of this bug is unnecessary. Leave issue to #705 #707 #788.
I want to switch this to fixed.

Note: See TracTickets for help on using tickets.