Ticket #418 (closed defect: wontfix)

Opened 12 years ago

Last modified 10 years ago

Power Button Timeouts too long

Reported by: mickey@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

Most people think that 5 seconds / 8 seconds is too long and would prefer 3
seconds / 5 seconds.

Change History

comment:1 Changed 12 years ago by laforge@…

  • Status changed from new to assigned

We can lower the '5 seconds'. but the '8 seconds' is a hardware definde
dimeout. no way to change that without changing pcf50606 silicon ;)

comment:2 Changed 12 years ago by alphaone@…

I agree, 3 seconds for regular power off seems much nicer. Of course we would
need some immediate feedback, that the phone is shutting down so the user
doesn't accidently hard power-off the device.

comment:3 Changed 12 years ago by mickey@…

Good, then lets go for the 3 seconds in U-Boot as well as the 3 seconds in
kernel for signalizing an event. I realize that the "hard-timeout" can't be
shortened, but since this only kicks in in emergency, it's probably ok.

comment:4 Changed 12 years ago by laforge@…

  • Status changed from assigned to new
  • Owner changed from laforge@… to werner@…

the kernel part (shutdown after 3 rather than 5 secods) is implemented in
Committed revision 1682.

u-boot actually already has three seconds. The problem is probably that you
don't notice it until two seconds later, when the splash has been loaded from
NAND and fully decompressed.

Werner?

comment:5 Changed 12 years ago by mickey@…

Thanks for the kernel part.

I don't think we have 3 seconds in U-boot, because the vibration pulse also only
comes after 5 seconds -- or is it written in a way that the pulse comes after
loading and showing the splash?

comment:6 Changed 12 years ago by laforge@…

yes, exactly. The way the splash is implemented is by first loading it from
nand, uncompressing, displaying it, enabling the backlight and then pulseing.
It should be the other way around.

In fact, the splash screen is even loaded from NAND and uncompressed if we push
the power button for less than three/five seconds, which is a waste of energy in
case the power button gets pressed accidentially (i.e. in a bag) a number of times.

Werner?

comment:7 Changed 11 years ago by willie_chen@…

  • Owner changed from werner@… to willie_chen@…

comment:8 Changed 11 years ago by willie_chen@…

Is it implemented?

comment:9 Changed 11 years ago by mickey@…

No.

comment:10 Changed 10 years ago by andy

How does current GTA02 behaviour on this match to desired behaviour?

comment:11 Changed 10 years ago by roh

  • Owner changed from willie_chen@… to willie_chen

comment:12 Changed 10 years ago by john_lee

  • Status changed from new to assigned
  • Owner changed from willie_chen to openmoko-kernel
  • HasPatchForReview unset

comment:13 Changed 10 years ago by andy

This seems to have come down to specifically GTA02 U-Boot behaviour around the power button. We will be moving off U-Boot to Qi which has no mode of sticking around in bootloader. For GTA02 case, remaining NOR U-Boot can't easily be changed anyway.

Unless I miss something I will close this as WONTFIX after delay for comment.

comment:14 Changed 10 years ago by arhuaco

  • Status changed from assigned to closed
  • Resolution set to wontfix
Note: See TracTickets for help on using tickets.