Ticket #45 (closed enhancement: community)

Opened 10 years ago

Last modified 8 years ago

Automatic opening input methods

Reported by: mickey@… Owned by: mickey
Priority: high Milestone:
Component: openmoko-libs Version: unspecified
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

InputMethods? should be opened automatically based on text input focus.

Change History

comment:1 Changed 10 years ago by mickey@…

  • Status changed from new to assigned

This is almost working w/ libgtkinput.

comment:2 Changed 10 years ago by stefan@…

We have this working now with matchbox-keyboard and it's new gtk-im code in OM2007.2

It works nice on some text inputs, but fails on others.

Working:


o Contacts phone and email addresses
o Search panel

Failing:


o Terminal application
o New contact: Name and organisation

comment:3 Changed 10 years ago by stefan@…

Robert Bradford fixed th problem with contacts in contacts svn rev 317.

Now only the terminal does not work which was to be expected as it is no gtk
application and can't work with gtk input methods.

comment:4 Changed 10 years ago by emreturkay@…

Don't we always need a keyboard when the terminal is on screen?

comment:5 Changed 10 years ago by mickey@…

Yes, we do, however as Stefan indicated we need to come up with a means to make
automatic opening possible w/ different toolkits.

comment:6 Changed 10 years ago by mickey@…

  • Severity changed from normal to enhancement

It works now for the terminal (since it´s a gtk application again), but still
not for different UI toolkits. Making this an "enhancement" now.

comment:7 Changed 9 years ago by mickey@…

  • Status changed from assigned to new
  • Severity changed from enhancement to blocker

comment:8 Changed 9 years ago by mickey@…

  • Severity changed from blocker to enhancement

comment:9 Changed 9 years ago by roh

  • Owner changed from mickey@… to mickeyl

comment:10 Changed 9 years ago by roh

  • Owner changed from mickeyl to mickey

comment:11 Changed 8 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community

om2007 related.

Note: See TracTickets for help on using tickets.