Ticket #482 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

phone still consumes energy when powered off

Reported by: mickey@… Owned by: laforge@…
Priority: high Milestone:
Component: Audio Version: GTA01Bv3
Severity: normal Keywords: Neo1973 Hardware
Cc: buglog@…, cw@…, tim_lee@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

tested w/ 2.6.20.7-moko9 on Bv3.

To reproduce: Issue poweroff on command line, then let device sit for 12 hours
-- battery completely drained and the device can no longer be turned on.

Change History

comment:1 Changed 12 years ago by mickey@…

confirmed on Bv4 as well. When it's (supposedly) turned off, you can even hear
static from the earphone speaker if you listen closely.

comment:2 Changed 12 years ago by laforge@…

  • Keywords Neo1973 Hardware added; OpenMoko removed
  • Cc tim_lee@… added
  • product changed from OpenMoko to Neo1973 Hardware
  • Version changed from unspecified to GTA01Bv3
  • Component changed from kernel to Audio

mh, thinking a bit about how our power-off works (sending shutdown command to
PMU), I could think the audio amplifier LM4857 could still be "alive":

This component is powered directly by the battery. We might not power it down
completely before software issues power-off, resulting in some remaining power
draw by the amplifier. Unfortunately there seems to be no series resistor
between VDD of the LM4857 and +VB. Maybe the hardware team has an idea on how
to measure LM4857 power consumption?

comment:3 Changed 12 years ago by speedevil@…

If the LM is oscillating, and taking all the power internally, it's tricky to
measure. If it's simply driving current through the speakers, then disconnecting
them will work.
Taking the plastic the speakers are mounted to off, and putting some tape over
the connectors should work just fine.

comment:4 Changed 12 years ago by laforge@…

apart from the audio amplifier there are other issues with the hardware that
we're looking into, somehow sometimes there is a loop of power-cycling between
the GSM and the AP part. Give us some time to investigate

comment:5 Changed 12 years ago by laforge@…

  • Status changed from new to closed
  • Resolution set to fixed

This is by now known as the 'Q1001' problem. Basically, while switching off the
S3C2410, the GSM Modem was reset by some spike on the nGSM_RESET line, which
caused the GSM Modem to power-up again.

This problem exists in GTA01Bv3 and early (phase-0) GTA01Bv4. Phase 1 GTA01Bv4
don't exhibit the problem anymore, since Q1001 was not placed during manufacturing.

comment:6 Changed 12 years ago by cw@…

  • Cc cw@… added
Note: See TracTickets for help on using tickets.