Ticket #51 (closed enhancement: wontfix)

Opened 12 years ago

Last modified 11 years ago

Preferences API

Reported by: mickey@… Owned by: mickey@…
Priority: high Milestone:
Component: openmoko-libs Version: unspecified
Severity: minor Keywords:
Cc: buglog@…, thomas@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

libmokocore needs a preferences API to read/write application preferences.

This should be implemented using gconf.

This may include an application session abstraction.

Change History

comment:1 Changed 12 years ago by jluebbe@…

  • blocked set to 341

comment:2 Changed 12 years ago by thomas@…

What would be the advantage of creating a separate configuration API above gconf?

comment:3 Changed 12 years ago by thomas@…

  • Cc thomas@… added

comment:4 Changed 11 years ago by willie_chen@…

Is gconf preferences still required or is this resolved another way?

comment:5 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to wontfix
  • Severity changed from normal to enhancement

Since there's so much resistance against high level APIs on top of Gtk+, I'm
closing this as WONTFIX.

Note: See TracTickets for help on using tickets.