Ticket #532 (closed enhancement: fixed)

Opened 12 years ago

Last modified 12 years ago

openmoko-dialer: make distcheck and autotools-related improvements

Reported by: rodolphe.ortalo@… Owned by: thomas@…
Priority: low Milestone:
Component: openmoko-dialer Version: current svn head
Severity: minor Keywords: VERIFIED
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Version and contact should be set in configure.ac
Some files are missing in Makefile.am , mostly *.h make dist fails).
On my machine, the compilation of ALSA headers also necessitates an additional
define.
imo dist_ automake builtin target can simplify data/Makefile.am

Attachments

dialer_making.patch (3.5 KB) - added by rodolphe.ortalo@… 12 years ago.
build patch to enable correct make distcheck

Change History

Changed 12 years ago by rodolphe.ortalo@…

build patch to enable correct make distcheck

comment:1 Changed 12 years ago by philippedeswert@…

  • Summary changed from make distcheck and autotools-related improvements to openmoko-dialer: make distcheck and autotools-related improvements

Edited summary so it better describes what the bug is about.

comment:2 Changed 12 years ago by laforge@…

  • Owner changed from tonyguan@… to thomas@…

comment:3 Changed 12 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

Patch applied in r2227. Thanks.

comment:4 Changed 12 years ago by rodolphe.ortalo@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Another "dist_" prefix is missing (due to later additions I think). Here is the
one liner needed:
Index: openmoko-dialer/data/Makefile.am
===================================================================
--- openmoko-dialer/data/Makefile.am (révision 2355)
+++ openmoko-dialer/data/Makefile.am (copie de travail)
@@ -51,7 +51,7 @@

# Dbus service file
#
servicedir = $(datadir)/dbus-1/services

-service_in_files = org.openmoko.Dialer.service.in
+dist_service_in_files = org.openmoko.Dialer.service.in

service_DATA = $(service_in_files:.service.in=.service)


# Expand the bindir in the service file

comment:5 Changed 12 years ago by njp@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Woops! That was me :-). Thanks I have fixed it in latest svn.

comment:6 Changed 12 years ago by rodolphe.ortalo@…

  • Keywords VERIFIED added
Note: See TracTickets for help on using tickets.