Ticket #533 (closed defect: wontfix)

Opened 12 years ago

Last modified 12 years ago

openmoko-footer: build and make distcheck related improvements

Reported by: rodolphe.ortalo@… Owned by: thomas@…
Priority: low Milestone:
Component: openmoko-footer Version: current svn head
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

A define for DBUS_API_SUBJECT_TO_CHANGE is needed for compilation on my machine.
Some *.h files are missing for make distcheck success.
IMHO dist_ builtin target can simplify the Makefile.am

Attachments

footer_making.patch (1.2 KB) - added by rodolphe.ortalo@… 12 years ago.
build and distcheck patch

Change History

Changed 12 years ago by rodolphe.ortalo@…

build and distcheck patch

comment:1 Changed 12 years ago by philippedeswert@…

  • Summary changed from build and make distcheck related improvements to openmoko-footer: build and make distcheck related improvements

Edited summary so it better describes what the bug is about.

comment:2 Changed 12 years ago by laforge@…

  • Owner changed from sunzhiyong@… to thomas@…

comment:3 Changed 12 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

distcheck is now fixed (r2221).

comment:4 Changed 12 years ago by rodolphe.ortalo@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Apparently, 2 files are missing now in the src/Makefile.am. Here is the one
liner diff I had to apply to build openmoko-footer:
Index: applications/openmoko-footer/src/Makefile.am
===================================================================
--- applications/openmoko-footer/src/Makefile.am (révision 2355)
+++ applications/openmoko-footer/src/Makefile.am (copie de travail)
@@ -10,6 +10,7 @@

footer.c footer.h \
callbacks.c callbacks.h \
taskmenu.c taskmenu.h \

+ taskitem.c taskitem.h \

misc.c misc.h


openmoko_footer_LDADD = @OPENMOKO_LIBS@

comment:5 Changed 12 years ago by stefan@…

  • Status changed from reopened to closed
  • Resolution set to wontfix

openmoko-footer is deprecated since OM2007.2

Closing as WONTFIX

Note: See TracTickets for help on using tickets.