Ticket #572 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Screensaver needs to ignore first click, and probably should force user through "unlock" sequence

Reported by: pavel@… Owned by: buglog@…
Priority: high Milestone:
Component: neod Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Ok, so I power openmoko on, it boots, logs into the network... and turns screen
off after timeout. I want to work with it, so I touch the screen...

...and machine starts to launch some application. Probably click on the dark
screen should be ignored.

And then... I put neo into my pocket and go on bycicle or something. When I pull
it out of my pocket, screen is shining most of the time. That means that:

1) neo was wasting power with backlight on in my pocket, because of the random
touchscreen touches

2) it was performing random operations.

Probably some kind of "touchscreen lock" should be implemented. "Screen locked,
press 911 button to unlock"? "Screen locked, touch top right corner then bottom
left corner to unlock"?

Attachments

1_lock-display.patch (5.8 KB) - added by olaf@… 11 years ago.
lock display gui
2_fix-warnings.patch (2.1 KB) - added by olaf@… 11 years ago.
fix all gcc warnings in neod
3_add-button-and-data.patch (2.0 KB) - added by olaf@… 11 years ago.
add button in power menu and images in Makefile.am
lock-images.tar.gz (66.7 KB) - added by olaf@… 11 years ago.
set of images for the display locker by IfChinsCouldKill?
moko_puzzle.tar.gz (114.3 KB) - added by olaf@… 11 years ago.
less offensive, but even cool images :)
moko_puzzle.tar.2.gz (113.7 KB) - added by olaf@… 11 years ago.
less offensive, but even cool images :) [NEW VERSION, PLEASE USE THIS ONE]

Change History

comment:1 Changed 12 years ago by philippedeswert@…

press power/other button and then press some button on the screen might be
better. It is pretty hard to hit one of the buttons. And the combination with
the onscreen button should avoid any complex touchscreen things. Just turn it
off when the screenlock comes on. If the power button is hit, turn on the
touchscreen and show the unlock button.

Changed 11 years ago by olaf@…

lock display gui

Changed 11 years ago by olaf@…

fix all gcc warnings in neod

Changed 11 years ago by olaf@…

add button in power menu and images in Makefile.am

comment:2 Changed 11 years ago by olaf@…

OpenMoko? display lock
=====================

Use case:
Willi wants to hear music when he is jogging, but he can't
because "lock down" gets his neo in suspend mode where he can't here
music and "dim only" won't prevent accidental triggering of events in his
pocket.

Idea:
Make an uncloseable widget, which can only be hidden when the user
draws a specific motion on the screen.

Realisation:
The user has to drag something from the buttom of the screen to the top
of the screen

Example:
[1] Is the start screen.
[2] The user starts dragging the white square.
[3] The white square is dragged to the top, the lock window disappears.

Help is needed:
Instead of dragging boring squares to boring rectangles the user could drag

  • key to key hole
  • cat to basket
  • finger to ring
  • something that one can put to another thing...

[4], [5], [6] and [7] are the example pictures that need to be replaced
by cool looking things.
You can send ideas and images to olaf@… or look for
"borg" in #openmoko

[1] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/start.png
[2] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/some_dragging.png
[3] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/end.png
[4] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/north.png
[5] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/mid.png
[6] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/south.png
[7] http://homepages.upb.de/olaf/dinge/openmoko/display_lock/drag.png

comment:3 Changed 11 years ago by mickey@…

  • Component changed from Host Software to neod

"Host Software" is the wrong category, this is about software that runs on the
target, in particular neod.

Changed 11 years ago by olaf@…

set of images for the display locker by IfChinsCouldKill?

Changed 11 years ago by olaf@…

less offensive, but even cool images :)

comment:4 Changed 11 years ago by olaf@…

  • attachments.isobsolete changed from 0 to 1

Changed 11 years ago by olaf@…

less offensive, but even cool images :) [NEW VERSION, PLEASE USE THIS ONE]

comment:5 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

applied in r3509. Great contribution, thanks a lot! P.S. We should read the
image filenames from gconv and add a moko display locking settings dialog to
openmoko-appearance :)

Note: See TracTickets for help on using tickets.