Ticket #583 (closed defect: wontfix)

Opened 11 years ago

Last modified 17 months ago

create an alsa state file that routes system audio to bluetooth

Reported by: bmidgley@… Owned by: willie_chen@…
Priority: high Milestone:
Component: kernel Version: unspecified
Severity: normal Keywords:
Cc: laforge@…, buglog@…, marcel@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Currently there is no way to route audio from a voip client for example to a
bluetooth headset. There is only a gsmbluetooth.state for using the gsm audio
with bluetooth.

Attachments

loopback_earphone.state (17.2 KB) - added by stefan@… 11 years ago.
loopback_earphone.state
loopback_receiver.state (17.2 KB) - added by stefan@… 11 years ago.
loopback_receiver.state
loopback_receiver_MIC2.state (17.2 KB) - added by stefan@… 11 years ago.
loopback_receiver_MIC2.state
loopback_speaker.state (17.2 KB) - added by stefan@… 11 years ago.
loopback_speaker.state
play_wav_earphone.state (17.2 KB) - added by stefan@… 11 years ago.
play_wav_earphone.state
play_wav_receiver.state (17.2 KB) - added by stefan@… 11 years ago.
play_wav_receiver.state
play_wav_speaker.state (17.3 KB) - added by stefan@… 11 years ago.
play_wav_speaker.state
btcpu.state (17.4 KB) - added by graeme@… 11 years ago.
CPU -> BT audio mapping.

Change History

comment:1 Changed 11 years ago by stefan@…

http://svn.openmoko.org/trunk/oe/packages/alsa/files/

Shows our currently deployed alsa state files. Besides the missing system -> bt
profile there are some more file in the DM2 dir of the P1 developer phones.

The loopback profiles don't make to much sense, but the play_wav_* could be
added to our standard alsa profile deploy. I'll add the files to this bug.

Changed 11 years ago by stefan@…

loopback_earphone.state

Changed 11 years ago by stefan@…

loopback_receiver.state

Changed 11 years ago by stefan@…

loopback_receiver_MIC2.state

Changed 11 years ago by stefan@…

loopback_speaker.state

Changed 11 years ago by stefan@…

play_wav_earphone.state

Changed 11 years ago by stefan@…

play_wav_receiver.state

Changed 11 years ago by stefan@…

play_wav_speaker.state

comment:2 Changed 11 years ago by laforge@…

  • Cc laforge@…, marcel@… added
  • Owner changed from laforge@… to graeme.gregory@…

adding graeme and marcel (maybe they can coordinate on providing the
asound.state for bluetooth headset audio)

comment:3 Changed 11 years ago by graeme@…

I either misunderstand this bug or I think you are looking at the wrong path for
audio. There is no reason to send audio via codec from CPU->codec->bluetooth.
CPU->bluetooth works and uses less power.

comment:4 Changed 11 years ago by graeme@…

btsco in OE BTW

comment:5 Changed 11 years ago by marcel@…

For the Bluetooth headset support we never route the SCO audio data to userspace
at all. They go from the Bluetooth chip's PCM directly to the GSM module or in
some cases to the microphone/speaker.

comment:6 Changed 11 years ago by graeme@…

Does this mean that you are requiring that all bluetooth audio goes via the
codec or that it is just not a case that is handled yet. The setup of the codec
is quite complex and we will have to power up quite a few parts of it. I would
have thought sending audio via USB (which is already powered) to bluetooth would
be economic solution power wise.

comment:7 Changed 11 years ago by graeme@…

Have double and triple checked the datasheet and the wm8753 cannot do full
duplex audio in this fashion. It was designed for the BT->digital->analog->GSM
path, allowing the applications CPU to sleep.

comment:8 Changed 11 years ago by marcel@…

Going through the HCI interface of the Bluetooth USB driver consumes probably
even more power. The SCO frames are using USB ISOC URBs for transmission. These
produce a big overhead. This would mean that the USB bus would have to really
busy. For the headset use case for example the number of control, interrupt and
bulk URBs is very small.

The other thing is latency since we have to do a lot copy to get the audio data
from one daemon into the other one. For the desktop we might be okay with that,
but the small Neo1973 device it is a bad idea.

So yes, the audio (SCO frames) from the Bluetooth chip should go directly into
the codec via the chip's PCM interface and then routed according to the codec
settings.

comment:9 Changed 11 years ago by bmidgley@…

the wm8753 cannot do full duplex audio in this fashion

Is there a different codec that we should suggest FIC use in the future to cover
this case?

In order to switch the chip from pcm to hci audio, it has to be reset. This
means all connections are lost so it can't be done transparently.

comment:10 Changed 11 years ago by laforge@…

just an update to the slightly off-topic thread into which this bug entry has
developed: We've started a discussion with Wolfson now on what the restrictions
actually are, and which codec to use for GTA02 and later models.

comment:11 Changed 11 years ago by bmidgley@…

Graeme, is it possible to make a .state file that routes system audio *out* to
the bluetooth headset? We could at least use this for custom ring tones to the
headset.

For audio input, using the built-in mic would be nice so we at least have an
option to use a voip app. Maybe cranking up the mic gain would make it usable
this way.

Changed 11 years ago by graeme@…

CPU -> BT audio mapping.

comment:12 Changed 11 years ago by john_lee@…

  • Owner changed from graeme@… to willie_chen@…

Willie, could you please check this ?

comment:13 Changed 11 years ago by andy@…

  • Status changed from new to assigned

comment:14 Changed 10 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to wontfix

Chip can't do what is requested any better than it is doing it.

comment:15 Changed 17 months ago by Chassmetly

Cheap Levitra Canada <a href=http://cialis.ccrpdc.com/can-i-buy-cialis-online.php>Can I Buy Cialis Online</a> Order Kamagra Oral Jelly Australia Buy Plavix Cheap <a href=http://prozac.ccrpdc.com/online-prozac.php>Online Prozac</a> Como Conseguir Viagra Sin Receta Medica Online Pharmacies Cialis 5 Mg <a href=http://kama1.xyz/generic-kamagra.php>Generic Kamagra</a> Rouitne Doses Of Amoxicillin Propecia Cost Order <a href=http://zol1.xyz/buy-zoloft-uk.php>Buy Zoloft Uk</a> Online Pharmacies Without Prescription Levitra Allergie <a href=http://cial5mg.xyz/cialis-free-trial.php>Cialis Free Trial</a> Buy Propecia Fedex Us Parmacy No Script Needed <a href=http://zol1.xyz/ordering-zoloft-online.php>Ordering Zoloft Online</a> Cytotec Temps D'Action Levitra Auf Naturbasis <a href=http://xenical.ccrpdc.com/order-alli.php>Order Alli</a> Potenzmittel Viagra Gratis Hydrochlorothiazide Mastercard Discount No Script Needed <a href=http://viag1.xyz/sildenafil.php>Sildenafil</a> Buy Wellbutrin Overnight Shipping Discount Progesterone Hormone Replacement Amex <a href=http://zol1.xyz/get-cheap-zoloft-online.php>Get Cheap Zoloft Online</a> Cialis E Priligy Buy Cialis In France <a href=http://cial5mg.xyz/cialis-5mg.php>Cialis 5mg</a> Priligy Kaufen Online Amoxil De Haute Qualite <a href=http://kama1.xyz/cheap-kamagra-generic.php>Cheap Kamagra Generic</a> Canada Drugstore Generic Pharmacy Levitra Und Aspirin <a href=http://cial1.xyz/buy-generic-cialis.php>Buy Generic Cialis</a> Efficacia Propecia Effetti Collaterali Zithromax To Treat Eczema <a href=http://cial5mg.xyz/purchase-generic-cialis.php>Purchase Generic Cialis</a> Kamagra Oral Jelly Generique Miglior Sito Per Acquisto Cialis <a href=http://kama1.xyz/where-can-i-buy-kamagra.php>Where Can I Buy Kamagra</a> isotretinoin order internet no physician approval Propecia O Pilexil <a href=http://kama1.xyz/kamagra-jelly-forum.php>Kamagra Jelly Forum</a> Cephalexin Drug Interaction Ibuprofin Generic Isotretinoin Skin Health Low Price <a href=http://zol1.xyz/zoloft-prices.php>Zoloft Prices</a> How Many Days To Take Amoxicillin Prix Du Levitra 10 Mag <a href=http://kama1.xyz/purchase-cheap-kamagra.php>Purchase Cheap Kamagra</a> Viagra Para El Deporte Lasix Side Effect <a href=http://viag1.xyz/sildenafil-citrate.php>Sildenafil Citrate</a> Viagra Cheap Usa Zithromax One Time Dose <a href=http://kama1.xyz/kamagra-jelly.php>Kamagra Jelly</a> Lilly Cialis Kaufen Buy Now Generic Dutasteride Mastercard Accepted Store Overnight <a href=http://kama1.xyz/buy-kamagra-usa.php>Buy Kamagra Usa</a> Propecia Front Scalp Cialis Generico Prezzo Farmacia <a href=http://zol1.xyz/sertraline-no-prescription.php>Sertraline No Prescription</a> Cephalexin Cat Alli Diet Pill Mexico <a href=http://viag1.xyz/viagra-prices.php>Viagra Prices</a> Keflex Anerobes Levitra Without A Script <a href=http://cial5mg.xyz/generic-cialis.php>Generic Cialis</a> Cialis In Vendita Plavix Buy Usa <a href=http://kama1.xyz/buy-kamagra-gel.php>Buy Kamagra Gel</a> Doxycycline On Line Doryx Jenacyclin In Internet <a href=http://prednisone.ccrpdc.com/cheap-deltasone.php>Cheap Deltasone</a> Generic Macrobid Online Articulo 195 <a href=http://nolvadex.ccrpdc.com/price-of-nolvadex.php>Price Of Nolvadex</a> Viagra Canada Paypal Fastest Viagra Delivery <a href=http://zol1.xyz/fast-delivery-zoloft.php>Fast Delivery Zoloft</a> Cialis Generique Vente En France

Note: See TracTickets for help on using tickets.