Ticket #600 (closed defect: wontfix)

Opened 12 years ago

Last modified 12 years ago

openmoko-dialer hardcodes widget sizes

Reported by: philipp.zabel@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-dialer Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

openmoko-dialer is unuseable on QVGA devices due to hardcoded widget sizes for
VGA. The attached patch hardcodes widget sizes for QVGA instead. This is equally
useless, but I put it here so I don't forget and to highlight the problematic
places.

Attachments

qvga.patch (17.6 KB) - added by philipp.zabel@… 12 years ago.
patch to fit openmoko-dialer into QVGA
qvga.2.patch (14.9 KB) - added by philipp.zabel@… 12 years ago.
patch to fit openmoko-dialer into QVGA
before.png (14.7 KB) - added by philipp.zabel@… 12 years ago.
screenshot of svn r2219
after.png (14.7 KB) - added by philipp.zabel@… 12 years ago.
screenshot of svn r2219 + patch #186
r2240.png (16.9 KB) - added by philipp.zabel@… 12 years ago.
screenshot of svn r2240, unpatched, with openmoko-theme-standard-qvga

Change History

comment:1 Changed 12 years ago by laforge@…

  • Owner changed from tonyguan@… to thomas@…

comment:2 Changed 12 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

I've removed the hard coded sizes from the dialer. If there is still a problem
with QVGA please re-open this bug.

comment:3 Changed 12 years ago by philipp.zabel@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Thanks for looking at this, but the fix in r2219 was really only the tip of the
iceberg. I'll attach an updated patch and two screenshots of r2219 without and
with the attached patch.

Changed 12 years ago by philipp.zabel@…

patch to fit openmoko-dialer into QVGA

comment:4 Changed 12 years ago by philipp.zabel@…

  • attachments.isobsolete changed from 0 to 1

Changed 12 years ago by philipp.zabel@…

screenshot of svn r2219

Changed 12 years ago by philipp.zabel@…

screenshot of svn r2219 + patch #186

comment:5 Changed 12 years ago by thomas@…

So it looks like the real issue is that the font sizes are fixed? There should
be no hard coding of sizes in the application if at all possible.

comment:6 Changed 12 years ago by thomas@…

I've committed a fix to the font sizes in the dial pad. Could you let me know
how this looks in QVGA?

Changed 12 years ago by philipp.zabel@…

screenshot of svn r2240, unpatched, with openmoko-theme-standard-qvga

comment:7 Changed 12 years ago by thomas@…

Thanks for the QVGA screenshot. Actually, this shows good progress, as it now
does not hard code any sizes. We are currently fixing bugs related to the icons
so that it should load properly when done. Please inform "nobody96" to update
his/her entire image.

I will now work on removing the hard coded font sizes from the number display.

comment:8 Changed 12 years ago by stefan@…

  • Status changed from reopened to closed
  • Resolution set to wontfix

openmoko-dialer2 from OM2007.2 should not suffer from this.

I close this bug with WONTFIX as OM2007 is deprecated now.

Note: See TracTickets for help on using tickets.