Ticket #602 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Python extensions not getting installed

Reported by: sudharsh@… Owned by: stefan@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I am having a weird problem wherein my python extensions arent getting installed
in the final build..Its getting compiled and the ipks are created where they
should. What is weird is that the build system tells me that the extension
module has been installed although when i try to import it i am getting a
"Module not found" error

NOTE: package python-pymoko-0.01-r0: task do_fetch: started
NOTE: package python-pymoko-0.01-r0: task do_fetch: completed
NOTE: package python-pymoko-0.01-r0: task do_unpack: started
NOTE: Unpacking /home/sudharsh/Projects/pymoko/pymoko-0.01.tar.gz to
/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/python-pymoko-0.01-r0/
NOTE: package python-pymoko-0.01-r0: task do_unpack: completed
NOTE: package python-pymoko-0.01-r0: task do_patch: started
NOTE: package python-pymoko-0.01-r0: task do_patch: completed
NOTE: package python-pymoko-0.01-r0: task do_configure: started
NOTE: package python-pymoko-0.01-r0: task do_configure: completed
NOTE: package python-pymoko-0.01-r0: task do_compile: started
NOTE: package python-pymoko-0.01-r0: task do_compile: completed
NOTE: package python-pymoko-0.01-r0: task do_install: started
NOTE: package python-pymoko-0.01-r0: task do_install: completed
NOTE: package python-pymoko-0.01-r0: task do_package: started
NOTE: package python-pymoko-0.01-r0: task do_package: completed
NOTE: package python-pymoko-0.01-r0: task do_package_write: started
NOTE: Not creating empty archive for python-pymoko-dbg-0.01-r0
Packaged contents of python-pymoko into
/home/sudharsh/Projects/openmoko/build/tmp/deploy/ipk/armv4t/python-pymoko_0.01-r0_armv4t.ipk
NOTE: Not creating empty archive for python-pymoko-doc-0.01-r0
NOTE: Not creating empty archive for python-pymoko-dev-0.01-r0
NOTE: Not creating empty archive for python-pymoko-locale-0.01-r0
NOTE: package python-pymoko-0.01-r0: task do_package_write: completed
NOTE: package python-pymoko-0.01-r0: task do_populate_staging: started
NOTE: package python-pymoko-0.01-r0: task do_populate_staging: completed
NOTE: package python-pymoko-0.01-r0: task do_build: started
NOTE: package python-pymoko-0.01-r0: task do_build: completed

I am attaching my bitbake recipe as well..

regards
Sudharshan S

Attachments

python-pymoko_0.01.bb (320 bytes) - added by sudharsh@… 12 years ago.
the bitbake recipe
python-pymoko.patch (1.1 KB) - added by stefan@… 12 years ago.
Add pymoko to buildsystem

Change History

Changed 12 years ago by sudharsh@…

the bitbake recipe

comment:1 Changed 12 years ago by stefan@…

  • Owner changed from mickey@… to stefan@…

I just tried your recipe. Adding it to task-openmoko and bumping the PR works
fine here. Python and your module will be installed in the rootfs.

/usr/lib/python2.4/site-packages/pymoko.so

The attached patch is my svn diff. Just your recipe with a SRC_URI change for
the tarball and the changes to task-openmoko.

Please try the following:

  1. Revert your own changes to svn, backup before, add my patch and test
  2. Completely remove the tmp dir under oe/build and start the build from scratch.

Changed 12 years ago by stefan@…

Add pymoko to buildsystem

comment:2 Changed 12 years ago by sudharsh@…

  • Status changed from new to closed
  • Resolution set to fixed

Yup..Building the stuff from scratch works..

Thanks a million

Sudharshan S

Note: See TracTickets for help on using tickets.