Ticket #607 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

flash.sh stalls

Reported by: roh@… Owned by: balrogg@…
Priority: high Milestone:
Component: qemu-neo1973 Version: current svn head
Severity: normal Keywords:
Cc: buglog@…, werner@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

stall till timeout in openmoko/flash.sh with u-boot
1.2.0-moko9_r10_9912121f7ed804ea58fd62f3f230b5dcfc357d88_0_2261

short debugging with werner boiled out to unbusy-i2c.patch in u-boot is the
interresting one. with it hangs, without not.

bug filed here since i am told it works on real hardware

Attachments

bug.txt (2.5 KB) - added by roh@… 12 years ago.
log

Change History

Changed 12 years ago by roh@…

log

comment:1 Changed 12 years ago by werner@…

  • Cc werner@… added

comment:2 Changed 12 years ago by balrogg@…

  • Owner changed from dodji@… to balrogg@…

comment:3 Changed 12 years ago by balrogg@…

  • Status changed from new to assigned

comment:4 Changed 12 years ago by balrogg@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Turns out PCF50606's IRQ pin output is inverted. This started to matter for
u-boot after the unbusy-i2c patch becuase it started using the IRQs instead of
polling through I2C.

Fixed in revision 2269.

Note: See TracTickets for help on using tickets.