Ticket #61 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Theme is very slow

Reported by: mickey@… Owned by: mickey@…
Priority: high Milestone:
Component: Theming - Gtk+ Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Find ways to improve the performance of the theming engine on the Neo1973

Attachments

D:\integer-pixops.patch (7.4 KB) - added by ken_zhao@… 12 years ago.
patch to add integer pixops implementation

Change History

comment:1 Changed 12 years ago by mickey@…

  • Severity changed from normal to major

comment:2 Changed 12 years ago by mickey@…

One way would be to update the 2nd patch from
http://bugzilla.gnome.org/show_bug.cgi?id=90621 to apply to Gtk+ 2.6.10 -- could
someone do that please?

comment:3 Changed 12 years ago by ken_zhao@…

FIC Shanghai don't have any develop board, so we can't test
the performance of theming engine. 2007-01-22

comment:4 Changed 12 years ago by jluebbe@…

  • blocked set to 341

comment:5 Changed 12 years ago by mickey@…

Now you have hardware, right? Can you do some tests, please?

comment:6 Changed 12 years ago by ken_zhao@…

reworked version of patch(http://bugzilla.gnome.org/attachment.cgi?id=78823)
I applied this patch, but it is unfinished.
"make_weights()" should be modified.

Can someone familiar with the pixops.c help to change?

Changed 12 years ago by ken_zhao@…

patch to add integer pixops implementation

comment:7 Changed 12 years ago by ken_zhao@…

time spent scaling (in seconds):

gtk 2.6.10 gtk 2.6.10 + integer-pixops.patch

gta01bv3 25.715657 25.660327

Testing program is
http://www.openembedded.org/repo/org.openembedded.dev/packages/gtk+/pixops-
test/pixops-test.c

comment:8 Changed 12 years ago by ken_zhao@…

(From update of attachment 55)
The patch will cause memory fault,please ignore it.

comment:9 Changed 12 years ago by ken_zhao@…

After debugging gtk-2.6.10, I found that 90% of scaling time is occupied by
function pixops_process(pixops.c:1019).
There ard less float operations in this function.
So I think no FPU is not the root cause of slow scaling.

comment:10 Changed 12 years ago by laforge@…

  • Owner changed from ken_zhao@… to mickey@…

comment:11 Changed 12 years ago by alphaone@…

We now use gtk-2.10 and have a different theme which feels much faster (as it
uses less pixmaps), but could still use some improvements.

comment:12 Changed 12 years ago by mickey@…

i think we're at the max regarding the pixmap theme. more speed can only be
realized by using a custom theme.

comment:13 Changed 11 years ago by mickey@…

Anyone tried the performance of the moko theme engine yet?

comment:14 Changed 11 years ago by willie_chen@…

Is it really blocker?

comment:15 Changed 11 years ago by mickey@…

  • Severity changed from major to normal

No. Priority has been lowered to 'normal'.

comment:16 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

We have a more lightweight Gtk+ theme now that uses less pixmaps. More
optimization might be possible by using the moko-gtk-engine or moving to a more
efficient toolkit and/or by dropping X.

Note: See TracTickets for help on using tickets.