Ticket #613 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Matchbox panel broken in Rev:2270

Reported by: sudharsh@… Owned by: stefan@…
Priority: high Milestone:
Component: openmoko-panel Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Matchbox panel-2 is broken in the current svn head (2270)

ccache arm-linux-gcc -march=armv4t -mtune=arm920t -DHAVE_CONFIG_H -I.

-I/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2/applets/startup
-I../.. -DPKGDATADIR=\"/usr/share/matchbox-panel\"
-DGETTEXT_PACKAGE=\"matchbox-panel\"
-DDATADIR=\"/usr/share/matchbox-panel/startup/\"
-isystem/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include
-Wall -g
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include/glib-2.0
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/lib/glib-2.0/include
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include/gtk-2.0
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/lib/gtk-2.0/include
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include/atk-1.0
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include/pango-1.0
-I/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include/freetype2
-I/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2
-I../.. -Werror
-isystem/home/sudharsh/Projects/openmoko/build/tmp/staging/arm-linux/include -O
-g -MT startup.lo -MD -MP -MF .deps/startup.Tpo -c startup.c -fPIC -DPIC -o
.libs/startup.o
| startup.c:35:22: error: libsn/sn.h: No such file or directory
| startup.c:52: error: expected specifier-qualifier-list before 'SnDisplay?'
| startup.c: In function 'show_hourglass':
| startup.c:74: error: 'StartupApplet?' has no member named 'hourglass_shown'
| startup.c: In function 'hide_hourglass':
| startup.c:80: error: 'StartupApplet?' has no member named 'hourglass_shown'
| startup.c: At top level:
| startup.c:83: error: expected ')' before '*' token
| startup.c: In function 'timeout':
| startup.c:153: error: 'StartupApplet?' has no member named 'hourglass_shown'
| startup.c:157: error: 'StartupApplet?' has no member named 'launch_list'
| startup.c:163: error: 'StartupApplet?' has no member named 'launch_list'
| startup.c:173: error: 'StartupApplet?' has no member named 'launch_list'
| startup.c:173: error: 'StartupApplet?' has no member named 'hourglass_shown'
| startup.c:178: error: 'StartupApplet?' has no member named 'hourglass_cur_frame_n'
| startup.c:179: error: 'StartupApplet?' has no member named 'hourglass_cur_frame_n'
| startup.c:180: error: 'StartupApplet?' has no member named 'hourglass_cur_frame_n'
| startup.c:184: error: 'StartupApplet?' has no member named 'hourglass_cur_frame_n'
| cc1: warnings being treated as errors
| startup.c: In function 'filter_func':
| startup.c:199: warning: implicit declaration of function
'sn_display_process_event'
| startup.c:199: error: 'StartupApplet?' has no member named 'sn_display'
| startup.c: In function 'mb_panel_applet_create':
| startup.c:209: error: 'SnMonitorContext?' undeclared (first use in this function)
| startup.c:209: error: (Each undeclared identifier is reported only once
| startup.c:209: error: for each function it appears in.)
| startup.c:209: error: 'context' undeclared (first use in this function)
| startup.c:214: error: 'StartupApplet?' has no member named 'launch_list'
| startup.c:231: error: 'StartupApplet?' has no member named 'sn_display'
| startup.c:231: warning: implicit declaration of function 'sn_display_new'
| startup.c:233: warning: implicit declaration of function 'sn_monitor_context_new'
| startup.c:233: error: 'StartupApplet?' has no member named 'sn_display'
| startup.c:235: error: 'monitor_event_func' undeclared (first use in this function)
| make[5]: * [startup.lo] Error 1
| make[5]: Leaving directory
`/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2/applets/startup'
| make[4]:
* [all-recursive] Error 1
| make[4]: Leaving directory
`/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2/applets/startup'
| make[3]: * [all-recursive] Error 1
| make[3]: Leaving directory
`/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2/applets'
| make[2]:
* [all-recursive] Error 1
| make[2]: Leaving directory
`/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2'
| make[1]: * [all] Error 2
| make[1]: Leaving directory
`/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/matchbox-panel-2'
| FATAL: oe_runmake failed
NOTE: Task failed:
/home/sudharsh/Projects/openmoko/build/tmp/work/armv4t-linux/matchbox-panel-2-0.1+svn20070615-r2/temp/log.do_compile.25825
NOTE: package matchbox-panel-2-0.1+svn20070615-r2: task do_compile: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package matchbox-panel-2-0.1+svn20070615: failed
ERROR: Build of openmoko-devel-image failed
make:
* [openmoko-devel-image] Error 1

regards
Sudharshan S

Change History

comment:1 Changed 12 years ago by stefan@…

Is there a reason this is assigned to Matthew?

It is just a dependendy problem on libstartup-notification. Normally this both
lines from our bitbake recipe should take care of it.

DEPENDS = "gtk+ apmd startup-notification"
EXTRA_OECONF = "--enable-startup-notification --disable-libnotify"

It builds fine for me with rev 2270. I'll try a rebuild from scratch now (Take
some time).

comment:2 Changed 12 years ago by sudharsh@…

I didnt realise that it could be a dependency issue. I figured since the issue
is related to matchbox-panel, i filed the bug under it.

Stefan, please reassign the bug as you deem fit. I will try rebuilding image
again after editing the recipe and report the results

Reggies,
Sudharshan S

comment:3 Changed 12 years ago by stefan@…

  • Owner changed from mallum@… to stefan@…

You should not need to edit the recipe if you use our overlay.

comment:4 Changed 12 years ago by sudharsh@…

  • Status changed from new to closed
  • Resolution set to fixed

Adding the lines as you suggested works, apparently my recipes arent getting
updated when i update the tree..The only change in the overlay in my tree is the
addition of one recipe, could it be the one stopping the updates?

reggies
Sudharshan S

comment:5 Changed 11 years ago by mickey@…

  • Component changed from matchbox-panel-2 to openmoko-panel
Note: See TracTickets for help on using tickets.