Ticket #622 (closed defect: invalid)

Opened 12 years ago

Last modified 12 years ago

mtd-utils-native

Reported by: yoyo@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

........
GNU Interactive Tools 4.3.20 (x86_64-pc-linux-gnu), 16:52:34 Jan 27 2007
GIT is free software; you can redistribute it and/or modify it under the
terms of the GNU General Public License as published by the Free Software
Foundation; either version 2, or (at your option) any later version.
Copyright (C) 1993-1999 Free Software Foundation, Inc.
Written by Tudor Hulubei and Andrei Pitis, Bucharest, Romania

git: fatal error: `chdir' failed: permission denied.
NOTE: Task failed: Fetch failed: Git: export
PATH=/home/moko/build/tmp/staging/x86_64-linux/bin:/home/moko/build/tmp/staging/x86_64-linux/bin:/home/moko/build/tmp/cross/bin:/home/moko/bitbake/bin:/bin:/usr/local/bin:/usr/bin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/3.4.6:/usr/x86_64-pc-linux-gnu/arm-unknown-linux-gnu/gcc-bin/4.1.2:/usr/x86_64-pc-linux-gnu/armeb-unknown-linux-gnu/gcc-bin/4.1.2:/opt/blackdown-jdk-1.4.2.03/bin:/opt/blackdown-jdk-1.4.2.03/jre/bin:/usr/kde/3.5/bin:/usr/qt/3/bin:/usr/games/bin:/opt/vmware/workstation/bin;
git pull git://git.infradead.org/mtd-utils.git failed
NOTE: package mtd-utils-native-1.0.0+git-r2: task do_fetch: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package mtd-utils-native-1.0.0+git: failed
ERROR: Build of openmoko-devel-image failed
make: * [openmoko-devel-image] Error 1

there is no such file in the moko home directory.

Change History

comment:1 Changed 12 years ago by hrw@…

  • Status changed from new to closed
  • Resolution set to invalid

You need to reconfigure system to have Torvalds GIT as "git" instead of GNU
Interactive Tools.

comment:2 Changed 12 years ago by yoyo@…

on my system helped
$ USE="bash-completion curl gtk mozsha1 perl"; emerge dev-util/git

rebuiling git with diffrents use

VERIFIED on gentoo

Note: See TracTickets for help on using tickets.