Ticket #65 (closed defect: community)

Opened 10 years ago

Last modified 9 years ago

Visual indication for SMS overflow

Reported by: mickey@… Owned by: chris
Priority: high Milestone:
Component: openmoko-panel Version: unspecified
Severity: major Keywords:
Cc: buglog@…, jserv@…, erin_yueh@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

is required by GSM 02.07 -- may add a dedicated panel applet for that or reuse
openmoko-missed-events-applet?

Attachments

openmoko-panel-memory_svn.bb (188 bytes) - added by chris@… 9 years ago.
bitbake recipe for openmoko-panel-memory

Change History

comment:1 Changed 10 years ago by laforge@…

  • dependson set to 21

comment:2 Changed 10 years ago by mickey@…

  • Severity changed from normal to major

comment:3 Changed 10 years ago by jluebbe@…

  • blocked set to 341

comment:4 Changed 10 years ago by jserv@…

  • Cc jserv@… added

comment:5 Changed 9 years ago by willie_chen@…

  • Owner changed from mickey@… to erin_yueh@…

It's belong GSM team, is there plan for this?

comment:6 Changed 9 years ago by mickey@…

It's a cross-layer issue, needs support both in gsmd and upper layers.

comment:7 Changed 9 years ago by erin_yueh@…

  • Status changed from new to assigned

comment:8 Changed 9 years ago by erin_yueh@…

  • Status changed from assigned to new
  • Owner changed from erin_yueh@… to chris@…

hi Chris,
about SMS memory full, it can be SIM card full or PHONE memory full. If it's SIM
card, it will receive a CMS error code 322 'GSM0705_CMS_MEMORY_FULL'. Could you
pop-up an error event to inform user. If it's PHONE memory full, could you
display a message MEMORY full indication on status bar? Thanks!

comment:9 Changed 9 years ago by chris@…

Do we want this to be a panel/systray applet then, as well as the notification?

comment:10 Changed 9 years ago by erin_yueh@…

  • Cc erin_yueh@… added

Yes, could we have this in panel?

comment:11 Changed 9 years ago by chris@…

  • Status changed from new to assigned

ok, implementing this should be pretty trivial, at least the SIM-full status
anyway. Do we have an icon for this?

comment:12 Changed 9 years ago by erin_yueh@…

umm..... i dont have any icon here.
since we can store SMS on both SIM and Phone memory, there are two cases.
if SIM is full, we display something like 'SIM card is full!' in panel.
if Phone is full, we display something like 'Phone memory is full!' in panel.

comment:13 Changed 9 years ago by chris@…

This all works now as much as is possible - When phone memory runs low, it
closes the phone's SMS store and waits until memory becomes available again (and
then reopens).

Indicator is a flashing GTK_SAVE icon in the panel and a notification pops up
saying what kind of memory has run low - the notification can be dismissed, the
panel applet will flash until the problem is resolved (if the notification is
still visible, it will also disappear on resolution).

Will attach a .bb with the panel applet.

Now waiting on gsmd interface to query current sms memory status and signal to
know when memory becomes free again (or I can poll a query if that's necessary)

Changed 9 years ago by chris@…

bitbake recipe for openmoko-panel-memory

comment:15 Changed 9 years ago by roh

  • Owner changed from chris@… to chris

comment:16 Changed 9 years ago by john_lee

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to community
Note: See TracTickets for help on using tickets.