Ticket #682 (closed defect: wontfix)

Opened 12 years ago

Last modified 11 years ago

OpenMoko compatible with T-Mobile Hotspot@Home

Reported by: harlyn@… Owned by: mickeyl
Priority: high Milestone:
Component: Applications & Dependencies Version: unspecified
Severity: wishlist Keywords:
Cc: buglog@…, cw@…, greg.hilton@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Are there any plans to make the OpenMoko? compatible with T-Mobile's Hotspot@Home
service? If not, it would be a great feature to see developed.

Change History

comment:1 Changed 12 years ago by stefan@…

Do you have some technical background or links about this feature? The marketing
name alone tells me nothing. :)

comment:2 Changed 12 years ago by cw@…

  • Cc cw@… added

comment:3 Changed 12 years ago by greg.hilton@…

T-Mobile HotSpot? @Home works as a home phone in your house and a mobile phone on
the go–so now you can have just one phone with all of your favorite features.
Use a T-Mobile HotSpot? Phone (that provides mobile and Wi-Fi calling) along with
a wireless router (T-Mobile offers specially designed routers for optimal
in-home performance) to get great coverage at home. In addition, by adding the
T-Mobile Hotspot @Home Add-On to their rate plan, customers will receive
unlimited nationwide calls from any Wi-Fi or US T-Mobile HotSpot? location.

Addition info can be found at:
http://support.t-mobile.com/knowbase/root/public/tm23449.htm
http://support.t-mobile.com/knowbase/root/public/tm23450.htm

comment:4 Changed 12 years ago by stefan@…

First of all we have to wait until we are ready to ship GTA02 phones, with
integrated wifi, and have fully working wifi support before we can think more
about this.

Unfortunately the sites not really states what _technically_ requirements are
needed on the phone to support this. Scanning for wifi networks is of course no
problem, but there are still some questions open:

1) What kind of VoIP protocol is used?
2) Open source software clients for linux?
3) At least linux clients?
4) ...

Once we have a detailed technical descriptions of the needed requirements on the
ohone side we can think about if and how to can use this.

I leave this bug open for further tracking.

comment:5 Changed 12 years ago by greg.hilton@…

  • Cc greg.hilton@… added

comment:6 Changed 12 years ago by greg.hilton@…

I tried contacting T-Mobile, but was not able to get to much information, but I
was able to get this much:
"..., please note that in order for a phone to work with the Hotspots @Home
service it is also required to have a dual-mode handset that is enabled to make
UMA calls. The current data devices that have Wi-Fi capability are only single
mode and will not allow a seamless connection between GSM and UMA."

So it looks like one of the requierments is to be runing GSM and Wi-Fi at the
same time. Perhapes someone can contact T-Mobile as a developer to get the rest
of the requierments.

comment:7 Changed 11 years ago by roh

  • Owner changed from mickey@… to mickeyl

comment:8 Changed 11 years ago by mickeyl

  • Status changed from new to closed
  • Resolution set to wontfix

unlikely to work with any Openmoko devices.

Note: See TracTickets for help on using tickets.