Ticket #683 (closed defect: duplicate)

Opened 12 years ago

Last modified 12 years ago

/etc/init.d/xserver-nodm not compatible with busybox's /bin/ps

Reported by: mail@… Owned by: buglog@…
Priority: normal Milestone:
Component: sysinit Version: unspecified
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The "/etc/init.d/xserver-nodm stop" command returns the following message, and
fails to kill 'xinit':

root@fic-gta01:/etc$ /etc/init.d/xserver-nodm stop
Stopping XServer
/bin/ps: invalid option -- e
BusyBox? v1.2.1 (2007.06.04-01:44+0000) multi-call binary

Usage: ps

root@fic-gta01:/etc$ ps | grep xinit

1158 root 720 S xinit /etc/X11/Xsession -- /usr/bin/Xfbdev :0 -br -pn
1332 root 632 S grep xinit

The init.d script tries to use "ps -e x" to get a list of running processes, but
the busybox implementation of /bin/ps does not accept any command-line arguments.

This can be fixed by using '/bin/pidof' to get the PID of xinit.

Observed on an openmoko-devel-image-fic-gta01-20070803091138 rootfs image built
using MokoMakefile?.

Attachments

xserver-nodm.patch (403 bytes) - added by mail@… 12 years ago.
Use 'pidof' rather than 'ps -e x'

Change History

Changed 12 years ago by mail@…

Use 'pidof' rather than 'ps -e x'

comment:1 Changed 12 years ago by mail@…

  • Status changed from new to closed
  • Resolution set to duplicate

* This bug has been marked as a duplicate of 605 *

Note: See TracTickets for help on using tickets.