Ticket #695 (closed defect: worksforme)

Opened 12 years ago

Last modified 11 years ago

Hold button on headset does not report events.

Reported by: speedevil@… Owned by: openmoko-kernel@…
Priority: normal Milestone:
Component: Audio Version: GTA01Bv4
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

hexdump -C /dev/input/event0

Jack insertion/removal, aux-button pressing produce events as expected.
Hold button on headset does not.

Verified by me, and two others on #openmoko.

I can't see anything clearly wrong with the kernel patches in this area.
If gpio.txt is accurate, it seems connected to the correct IO.

Change History

comment:1 Changed 11 years ago by tick@…

  • Owner changed from sean_chiang@… to willie_chen@…

comment:2 Changed 11 years ago by willie_chen@…

  • Owner changed from willie_chen@… to michael@…

comment:3 Changed 11 years ago by speedevil@…

Still does not work on latest kernel

comment:4 Changed 11 years ago by mwester@…

  • Owner changed from michael@… to openmoko-kernel@…

comment:5 Changed 11 years ago by andy@…

  • Status changed from new to closed
  • Resolution set to worksforme

The HOLD button only works when MICBIAS is enabled, which only happens when the
amp is powered up. There's not much to be done about this since it is a
"feature" of the hardware design.

I verified it by using DM2 headset test and hexdumping /dev/input/event0, it can
probably also be confirmed by setting "Mic Sidetone Mux" to "Mic2" in alsamixer
while hexdumping (worked here but not sure what other settings have to be
enabled there).

I'm closing as WORKSFORME but unless you know this little foible of course it
doesn't work for me or anyone else.

Note: See TracTickets for help on using tickets.