Ticket #703 (closed defect: worksforme)

Opened 12 years ago

Last modified 12 years ago

RTC readings corrupt in userland

Reported by: mickey@… Owned by: laforge@…
Priority: high Milestone:
Component: kernel Version: unspecified
Severity: blocker Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

pcf50606_rtc_read_time shows it's correct:

Jul 31 23:25:36 fic-gta01 user.warn kernel: pcf50606_rtc_read_time: PCF_TIME:
31.06.fe 23:25:36
Jul 31 23:25:36 fic-gta01 user.warn kernel: pcf50606_rtc_read_time: RTC_TIME:
31.6.264 23:25:36
Jul 31 23:25:39 fic-gta01 user.warn kernel: adc_read: entering (pcf=c07dac00,
channel=0, data2=00000000)
Jul 31 23:25:39 fic-gta01 user.warn kernel: pcf50606_irq: entering(irq=60,
pcf=c07dac00): scheduling work
Jul 31 23:25:39 fic-gta01 user.warn kernel: pcf50606_work: INT1=0x40 INT2=0x00
INT3=0x01:SECOND ADCRDY
Jul 31 23:25:39 fic-gta01 user.warn kernel: adc_read: returning 661 0

However, it doesn't make it to userland:

root@fic-gta01:~$ hwclock -r
Wed Dec 31 23:59:59 1969 0.000000 seconds

Change History

comment:1 Changed 12 years ago by alphaone@…

root@fic-gta01:~$ hwclock
Tue Aug 21 00:12:55 2007 0.000000 seconds
root@fic-gta01:~$ hwclock
Tue Aug 21 00:12:59 2007 0.000000 seconds
root@fic-gta01:~$ dmesg -c
<4>pcf50606_rtc_read_time: PCF_TIME: 21.07.07 00:12:55
<4>pcf50606_rtc_read_time: RTC_TIME: 21.7.107 0:12:55
<4>pcf50606_rtc_read_time: PCF_TIME: 21.07.07 00:12:59
<4>pcf50606_rtc_read_time: RTC_TIME: 21.7.107 0:12:59

Hmm, it works for me...
Using 2.6.22.1-moko10

comment:2 Changed 12 years ago by laforge@…

also works here.

To the original bug reporter: Please provide the exact kernel version on which
you observe this problem. 'uname -a' would help.

comment:3 Changed 12 years ago by laforge@…

  • Status changed from new to closed
  • Resolution set to worksforme

original reporter never got back, and it works fine for most people.

Note: See TracTickets for help on using tickets.