Ticket #704 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

/etc/init.d/gsmd kills self.

Reported by: schrock.brian@… Owned by: buglog@…
Priority: high Milestone:
Component: sysinit Version: 2007
Severity: trivial Keywords:
Cc: buglog@…, kristian@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I am using this image through qemu and my phone...

openmoko-devel-image-fic-gta01-20070803091138.rootfs.jffs2

The init script /etc/init.d/gsmd, in the stop() function, contains the
line 'killall gsmd', and I think it is killing itself as well as the gsmd
daemon before it continues on to remove the file in /var/lock/subsys/gsmd.

Not always but it has left me with the file /var/lock/subsys/gsmd and because
of that gsmd fails to start on the next boot.

Attachments

gsmd (2.4 KB) - added by schrock.brian@… 12 years ago.
A Modified gsmd script.
gsmd.2 (2.4 KB) - added by schrock.brian@… 12 years ago.
Bugfix on the gsm init.d script.
gsmd.3 (3.2 KB) - added by schrock.brian@… 12 years ago.
Working and tested gsmd init script.
gsmd_startup_error.patch (471 bytes) - added by kristian@… 12 years ago.
removing '&' behind start-stop-daemon, to make $? valid

Change History

Changed 12 years ago by schrock.brian@…

A Modified gsmd script.

comment:1 Changed 12 years ago by schrock.brian@…

  • attachments.isobsolete changed from 0 to 1

comment:2 Changed 12 years ago by schrock.brian@…

  • attachments.isobsolete changed from 0 to 1

comment:3 Changed 12 years ago by mickey@…

  • Status changed from new to assigned

I have commited a different script utilizing start-stop-daemon from busybox to
OE fa056f4e1e3e3e49a96459c011ccfcb235a4f695. Does that fix it?

comment:4 Changed 12 years ago by mickey@…

  • Cc kristian@… added

* Bug 751 has been marked as a duplicate of this bug. *

comment:5 Changed 12 years ago by mickey@…

  • Status changed from assigned to closed
  • Resolution set to fixed

seems to work fine. closing it for now.

Changed 12 years ago by kristian@…

removing '&' behind start-stop-daemon, to make $? valid

comment:6 Changed 12 years ago by kristian@…

  • attachments.isobsolete changed from 0 to 1

(From update of attachment 269)
Other than pulseaudio gsmd does not go into daemonmode. So '-b' must be added
or we stick with '&' - there will be no valid $? anyway.

Note: See TracTickets for help on using tickets.