Ticket #706 (closed defect: wontfix)

Opened 12 years ago

Last modified 2 years ago

libgsm does not build as timestamped filenames change

Reported by: andreas@… Owned by: laforge@…
Priority: high Milestone:
Component: libgsmd Version: 2007
Severity: major Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

building libgsmd-0.1+svnnow in bitbake does not work and exits during
installation with the following message:

| NOTE: make
DESTDIR=/home/moko/build/tmp/work/armv4t-linux/libgsmd-0.1+svnnow-r0_0_200708150003/image
install
| make: * No rule to make target `install'. Stop.
| FATAL: oe_runmake failed

The problem seems to be a bitbake problem as the timestamped filename does
change between the different macro calls:

NOTE: package libgsmd-0.1+svnnow: started
NOTE: package libgsmd-0.1+svnnow-r0_0_200708150002: task do_fetch: started
NOTE: Update svn://svn.openmoko.org/trunk/src/target;module=gsm;proto=http
At revision 2702.

Here the time is 00:02

NOTE: package libgsmd-0.1+svnnow: started
NOTE: package libgsmd-0.1+svnnow-r0_0_200708150003: task do_install: started

Install is called at 00:03 resulting in a different timestamped filename. The
directory in question is empty explaining why the install target cannot be found
as no Makefile is present.

Resetting the time at the appropriate time in a second window via date -s does
make the build complete.

Attachments

log (5.3 KB) - added by andreas@… 12 years ago.
Buildlog showing the problem

Change History

Changed 12 years ago by andreas@…

Buildlog showing the problem

comment:1 Changed 12 years ago by stefan@…

Do you use the old svn overlay or OE.dev directly?

Which bitbake version?

svn overlay needs 1.6.6
OE.dev needs 1.8.6

I run once into such a problem with the wrong bitbake version in regard to the
meta data. Let me know if it works with the right combination.

comment:2 Changed 12 years ago by andreas@…

bitbake was 1.8.6

comment:3 Changed 12 years ago by andreas@…

comment:4 Changed 12 years ago by stefan@…

Do you still have this problem?

Please try it again with using OE.dev directly. The new MokoMakefile? should take
care of this. http://wiki.openmoko.org/wiki/MokoMakefile

Of course you can also use bitbake and the oe metadata directly. We need some
time to update all the instructions in the wiki

comment:5 Changed 12 years ago by mickey@…

Thanks for reporting. This is a known bug in BitBake?.

The best way to workaround is to just bitbake -c rebuild <the offending package>.

comment:6 Changed 11 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to wontfix

closing here, since this is an OE problem.

comment:7 Changed 2 years ago by Chassmetly

Cialis Boite <a href=http://kamagra.ccrpdc.com>Buy Kamagra</a> Protonix 20 Mg Buy Acheter Amoxicillin Distribuer <a href=http://strattera.ccrpdc.com/can-i-buy-strattera-online.php>Can I Buy Strattera Online</a> El Viagra Ayuda A Durar Mas Viagra Frau Rezeptfrei <a href=http://zol1.xyz/best-zoloft-online.php>Best Zoloft Online</a> Thyrox Order Online No Prescription Priligy 90mg <a href=http://kama1.xyz/buy-kamagra-oral-jelly-online.php>Buy Kamagra Oral Jelly Online</a> Isotretinoin With Next Day Delivery Cod Only Where Can I Buy Isotretinoin North Ayrshire <a href=http://priligy.ccrpdc.com/priligy-dapoxetine-online.php>Priligy Dapoxetine Online</a> Dexahasone Europe Pharmacy Online <a href=http://zol1.xyz/getting-zoloft-overseas.php>Getting Zoloft Overseas</a> Propecia En Espana Online Viagra Rezeptpflichtig Holland <a href=http://zol1.xyz/implicane-online.php>Implicane Online</a> Prescription Levitra Achat Viagra Y Taquicardia <a href=http://zol1.xyz/buy-cheap-zoloft-pills.php>Buy Cheap Zoloft Pills</a> Levaquin Order Tablets Tadalis Sx Soft Chef Projet Moa <a href=http://cial5mg.xyz/get-cheap-cialis-online.php>Get Cheap Cialis Online</a> Buy Propecia Black Online Buy Amoxil Online <a href=http://cial1.xyz/cheap-cialis-20mg.php>Cheap Cialis 20mg</a> Acquisto Cialis E Viagra Best Place Buy Cialis Online <a href=http://zol1.xyz/cost-of-zoloft.php>Cost Of Zoloft</a> Order Tamoxifen Cheap Online Levitra <a href=http://cial5mg.xyz/tadalafil-online.php>Tadalafil Online</a> Effects Of Mixing Keflex And Beer Amoxicillin And Clavulanate <a href=http://viag1.xyz/viagra-free-trial.php>Viagra Free Trial</a> Propecia While On Isotretinoin Tadalafil Generic Vs Cialis <a href=http://zol1.xyz/zoloft-online-cs.php>Zoloft Online Cs</a> Acheter Du Cytotec En Ligne Kamagra Sverige <a href=http://cial5mg.xyz/generic-cialis-100mg.php>Generic Cialis 100mg</a> Cialis Come Funziona Keflex Vaginal Bacteria <a href=http://cial1.xyz/buy-cialis-cheap.php>Buy Cialis Cheap</a> Buy Viagra Pzifer Brand Commander Du Viagra <a href=http://viag1.xyz/viagra-online-stores.php>Viagra Online Stores</a> Prix Du Propecia Au Canada Levitra Tab <a href=http://viag1.xyz/buy-viagra.php>Buy Viagra</a> Amoxicillin Dosage Infection Sinus Buy Accutane Online Legit <a href=http://kama1.xyz/order-kamagra-in-usa.php>Order Kamagra In Usa</a> Levitra Chez La Femme Pharmace Online <a href=http://kama1.xyz/purchase-kamagra.php>Purchase Kamagra</a> Etienne Kamagra In Linea Cialis Pressione Alta <a href=http://cial1.xyz/need-to-order-cialis.php>Need To Order Cialis</a> Cialis En Capital Federal Viagra Pfizer Prezzo <a href=http://cial1.xyz/low-cost-cialis-online.php>Low Cost Cialis Online</a> Cialis Quand Le Prendre 30mg Le Priligy Generique <a href=http://cial1.xyz/cialis-free-trial.php>Cialis Free Trial</a> Traitement Cialis Levitra Viagra Pillen Nebenwirkungen <a href=http://zol1.xyz/cheap-zoloft-no-rx.php>Cheap Zoloft No Rx</a> Acquistare Viagra In Contrassegno

Note: See TracTickets for help on using tickets.