Ticket #723 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Today switches selected entry on tab change

Reported by: mickey@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-today Version: unspecified
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Select an entry, then switch from application startup tab to a different tab and
then switch back. You will find the selected entry has moved.

Change History

comment:1 Changed 12 years ago by mickey@…

  • Owner changed from buglog@… to thomas@…

comment:2 Changed 12 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

This should be fixed now. It is caused by a bug that affects the selection in
libtaku when the widget is refocused. However, on the Neo1973, it doesn't make
much sense to have a selection as we don't have any keys or buttons that make it
useful, so I will remove the selection colour altogether from the theme.

comment:3 Changed 12 years ago by mickey@…

Please don't remove the selection. It is very helpful on devices like the
Motorola EZX series which have cursor keys / jog wheel / etc.

Note: See TracTickets for help on using tickets.