Ticket #734 (closed defect: invalid)

Opened 12 years ago

Last modified 12 years ago

openmoko-devel-image fails with extra python packages

Reported by: mike@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

openmoko-devel-image fails with this error in the extra python packages. It
should be fairly self-explanatory.

| + for i in '/moko/build/tmp/rootfs/usr/lib/ipkg/info/*.postinst'
| + '-f /moko/build/tmp/rootfs/usr/lib/ipkg/info/settings-daemon.postinst?'
| + sh /moko/build/tmp/rootfs/usr/lib/ipkg/info/settings-daemon.postinst configure
| ++ basename /moko/build/tmp/rootfs/usr/lib/ipkg/info/settings-daemon.postinst
.postinst
| + ipkg-cl -f
/moko/build/tmp/work/fic-gta01-angstrom-linux-gnueabi/openmoko-devel-image-1.0-r0/temp/ipkg.conf
-o /moko/build/tmp/rootfs flag unpacked settings-daemon
| Setting flags for package settings-daemon to unpacked
| Successfully terminated.
| + for i in '/moko/build/tmp/rootfs/usr/lib/ipkg/info/*.postinst'
| + '-f /moko/build/tmp/rootfs/usr/lib/ipkg/info/ttf-bitstream-vera.postinst?'
| + sh /moko/build/tmp/rootfs/usr/lib/ipkg/info/ttf-bitstream-vera.postinst
configure
| + for i in '/moko/build/tmp/rootfs/usr/lib/ipkg/info/*.postinst'
| + '-f /moko/build/tmp/rootfs/usr/lib/ipkg/info/udev-utils.postinst?'
| + sh /moko/build/tmp/rootfs/usr/lib/ipkg/info/udev-utils.postinst configure
| /moko/build/tmp/rootfs/usr/lib/ipkg/info/udev-utils.postinst: line 10:
/etc/udev/mount.blacklist: Permission denied
| + for i in '/moko/build/tmp/rootfs/usr/lib/ipkg/info/*.postinst'
| + '-f /moko/build/tmp/rootfs/usr/lib/ipkg/info/xserver-nodm-init.postinst?'
| + sh /moko/build/tmp/rootfs/usr/lib/ipkg/info/xserver-nodm-init.postinst configure
| Adding system startup for /moko/build/tmp/rootfs/etc/init.d/xserver-nodm ...
| /moko/build/tmp/rootfs/etc/rc5.d/S99xserver-nodm -> ../init.d/xserver-nodm
| /moko/build/tmp/rootfs/etc/rc2.d/S99xserver-nodm -> ../init.d/xserver-nodm
| /moko/build/tmp/rootfs/etc/rc0.d/K20xserver-nodm -> ../init.d/xserver-nodm
| /moko/build/tmp/rootfs/etc/rc1.d/K20xserver-nodm -> ../init.d/xserver-nodm
| /moko/build/tmp/rootfs/etc/rc6.d/K20xserver-nodm -> ../init.d/xserver-nodm
| + install -d /moko/build/tmp/rootfsetc
| + echo 200708211016
| + date +%m%d%H%M%Y
| + log_check rootfs
| + set +x
| log_check: Using
/moko/build/tmp/work/fic-gta01-angstrom-linux-gnueabi/openmoko-devel-image-1.0-r0/temp/log.do_rootfs.704
as logfile
| log_check: There were error messages in the logfile
| log_check: Matched keyword: [ERR]
|
| Downloading
file:/moko/build/tmp/deploy/glibc/ipk/armv4t/libgcrypt11_1.2.3-r0_armv4t.ipk
| Installing libgpg-error0 (1.4-r1) to root...
| Downloading
file:/moko/build/tmp/deploy/glibc/ipk/armv4t/libgpg-error0_1.4-r1_armv4t.ipk
| Installing libxcursor1 (1:1.1.8-r2) to root...
| --
| (offline root mode: not running libgnutls13.postinst)
| Configuring libgpg-error0
| (offline root mode: not running libgpg-error0.postinst)
| Configuring libgsmd-tools
| --
| Successfully terminated.
| Collected errors:
| ERROR: Cannot satisfy the following dependencies for task-base:
| python-zlib python-resource python-gdbm python-fcntl python-zlib
python-crypt
| --
| + for i in '/moko/build/tmp/rootfs/usr/lib/ipkg/info/*.postinst'
| + '-f /moko/build/tmp/rootfs/usr/lib/ipkg/info/libgpg-error0.postinst?'
| + sh /moko/build/tmp/rootfs/usr/lib/ipkg/info/libgpg-error0.postinst configure
| + for i in '/moko/build/tmp/rootfs/usr/lib/ipkg/info/*.postinst'
|
NOTE: Task failed:
/moko/build/tmp/work/fic-gta01-angstrom-linux-gnueabi/openmoko-devel-image-1.0-r0/temp/log.do_rootfs.704
NOTE: package openmoko-devel-image-1.0-r0: task do_rootfs: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package openmoko-devel-image-1.0: failed
ERROR: Build of /moko/openembedded/packages/images/openmoko-devel-image.bb
do_rootfs failed
ERROR: Task 4 (/moko/openembedded/packages/images/openmoko-devel-image.bb,
do_rootfs) failed
NOTE: Tasks Summary: Attempted 3430 tasks of which 2466 didn't need to be rerun
and 1 failed.
ERROR: '/moko/openembedded/packages/images/openmoko-devel-image.bb' failed
make: * [openmoko-devel-image] Error 1

Change History

comment:1 Changed 12 years ago by mike@…

local.conf is this

=========================================

MACHINE = "fic-gta01"
DISTRO = "openmoko"
BUILD_ARCH = "i686"

PARALLEL_MAKE = "-j 4"
BB_NUMBER_THREADS = "4"

DISTRO_EXTRA_RDEPENDS += "python-pygtk python-pycairo python-profile
python-threading python-distutils python-textutils python-codecs python-pickle
python-datetime python-core python-io python-compiler python-compression
python-re python-xmlrpc python-email python-image python-resource python-math
python-unixadmin python-tkinter python-gdbm python-html python-subprocess
python-mailbox python-xml python-mime python-zlib python-db python-crypt
python-audio librsvg"

comment:2 Changed 12 years ago by stefan@…

I'm not sure why you think that is an openmoko bug, but no general OE bug?

comment:3 Changed 12 years ago by mike@…

The package which is failing is openmoko-devel-image which I assumed was to do
with openmoko rather than OE. Should I be reporting this bug to OE instead?

comment:4 Changed 12 years ago by stefan@…

It fails with this error:

| Collected errors:
| ERROR: Cannot satisfy the following dependencies for task-base:
| python-zlib python-resource python-gdbm python-fcntl python-zlib
python-crypt

And you have the following selfmade modification:

DISTRO_EXTRA_RDEPENDS += "python-pygtk python-pycairo python-profile
python-threading python-distutils python-textutils python-codecs python-pickle
python-datetime python-core python-io python-compiler python-compression
python-re python-xmlrpc python-email python-image python-resource python-math
python-unixadmin python-tkinter python-gdbm python-html python-subprocess
python-mailbox python-xml python-mime python-zlib python-db python-crypt
python-audio librsvg"

So you added the python packages yourself. It fails not due to normal
openmoko-devel-image behaviour.

Besides this, IIRC there were something about broken python-crypt in OE.dev the
last days. Do you tried with the newest stuff pulled and updated in OE.dev?

comment:5 Changed 12 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to invalid

You can not just add arbitrary packages to DISTRO_EXTRA_RDEPENDS and expect them
being automagically built before image generation time. Please don't fiddle with
DISTRO_EXTRA_RDEPENDS, but add you own custom image.bb instead. There you can
just use RDEPENDS / PACKAGES to drag more stuff into the image.

Note: See TracTickets for help on using tickets.