Ticket #76 (closed enhancement: fixed)

Opened 12 years ago

Last modified 11 years ago

Implement PWM control for vibrator

Reported by: laforge@… Owned by: laforge@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: minor Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

required to have different vibrator levels

Change History

comment:1 Changed 12 years ago by laforge@…

this is not possible since the vibrator is not connected to a PWM capable GPIO.

Hardware-TODO for GTA01Bv4?

comment:2 Changed 12 years ago by sean_mosko@…

  • Owner changed from laforge@… to teddy@…
  • Milestone set to Phase 0

comment:3 Changed 12 years ago by laforge@…

This has been changed in the current GTA01Bv4 design, i.e. we will be able to do
PWM on the vibrator at that point.

comment:4 Changed 12 years ago by laforge@…

  • Milestone changed from Phase 0 to Phase 1

putting this into phase1 since we don't have hardware for this yet

However, a driver similar to gta01bl.c can be written.

comment:5 Changed 12 years ago by laforge@…

  • Owner changed from teddy@… to laforge@…

comment:6 Changed 12 years ago by mickey@…

I lost track. Which device revisions implement this and what's the interface?

comment:7 Changed 12 years ago by laforge@…

All hardware >= GTA01Bv4 has the capability of doing PWM on the vibrator.

However, the kernel driver for this was never implemented.

The bad news is that there just is no standard interface on how to control a
non-backlight pwm from userspace, so we have to invent our own interface, again.

However, that driver should be generic enough to cover all the s3c24xx PWM's
that we use, i.e. also for LED brightness control on GTA02.

comment:8 Changed 12 years ago by laforge@…

  • Status changed from new to closed
  • Resolution set to fixed

this has been committed as of svn rev. 3137

comment:9 Changed 11 years ago by anonymous

  • Milestone Phase 1 deleted

Milestone Phase 1 deleted

Note: See TracTickets for help on using tickets.