Ticket #773 (closed enhancement: community)

Opened 10 years ago

Last modified 3 months ago

Qemu should support -net usb -redir ......

Reported by: hozer@… Owned by: michael
Priority: high Milestone:
Component: qemu-neo1973 Version: current svn head
Severity: minor Keywords:
Cc: buglog@…, balrogg@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The qemu-neo1973 emulator should be able to fake a host with USB networking such
that the qemu user networking stack can allow a redirected connection without
needing a linux host with the dummy_hcd and gadgetfs modules loaded.

Change History

comment:1 Changed 10 years ago by balrogg@…

  • Status changed from new to closed
  • Cc balrogg@… added
  • Resolution set to invalid

qemu should not fake any part of the host, whatever is emulated is by definition
the emulation target. Qemu already provides enough interface for a separate
process to be able to fake this part of the host, although linux + dummy_hcd +
gadgetfs do exactly this and I don't think it's worth reimplementing in userspace.

If you are unable to run a linux kernel directly on your host (note that this
would cause you problems with a physical Neo1973 as well), run it in qemu, which
is cross-platform.

comment:2 Changed 10 years ago by hozer@…

  • Status changed from closed to reopened
  • rep_platform changed from PC to Other
  • Resolution invalid deleted
  • op_sys changed from Linux to All

The neo usb networking is supposed to work from both linux and windows (I am not
sure about MacOSX).

Having to (re)compile gadgetfs and dummy_hcd to be able to log into the emulated
neo via ssh seems quite silly to me. It's confusing for new users, and makes it
much more difficult and expensive to use the emulator on Windows or MacOSX. I
did get it working on my laptop, but not on my build host which is running
debian etch with a 2.6.18 kernel. (gadgetfs and dummy_hcd continously spewed errors)

It would be extremely nice to have a qemu binary package for both Windows and
OSX that can allow someone wanting to try out the openmoko device without having
to run an emulator in an emulator.

Must we close this? Can't we leave it open as an enhancement for someone in the
community to fix?

comment:3 Changed 10 years ago by balrogg@…

It would work in Windows and MacOS if they didn't lack gadgetfs support - this
lack should be compensated for in these projects instead of in qemu. Ofcourse if
someone implements a workaround in qemu (which shouldn't be difficult because it
would mainly consist of copying and pasting the kernel code into qemu) it can be
merged into qemu-neo1973 tree, but not upstream. See the problems qemu already
has with maintaining slirp in our cvs - this would add a very similar issue of
maintaining code that belongs in a separate project.

For networking, fixing the USB NIC from
http://lists.gnu.org/archive/html/qemu-devel/2006-11/msg00044.html may be
easier. Other possibilities are networking over emulated bluetooth or GPRS but
they will have the same problems of a lot of code not fitting in qemu.

comment:4 Changed 10 years ago by john_lee@…

  • Owner changed from dodji@… to balrogg@…
  • Status changed from reopened to new

Andrzej, please decide what to do with this. If we leave it to the community
please reassign to michael@…

comment:5 Changed 10 years ago by balrogg@…

  • Owner changed from balrogg@… to michael@…

Yes, it's an enhancement and it doesn't really belong in qemu-neo1973 (it's not
tied specifically to GTA01 emulation) so let's leave it open with Severity set
to "enhancement".

In the meantime Tuukkah proposed networking between host and the Neo through
pppd, which is also quite painless to establish.

comment:6 Changed 9 years ago by roh

  • Owner changed from michael@… to michael

comment:7 Changed 9 years ago by john_lee

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to community

comment:8 Changed 3 months ago by JustDox

What Is Ephadraxin <a href=http://kama1.xyz/kamagra-online-fast.php>Kamagra Online Fast</a> Tadalis Sx Soft Tabs Candian No Script Pharmacy <a href=http://priligy.ccrpdc.com/buying-pills-online.php>Buying Pills Online</a> Amoxicillin Side Afec Cialis And Viagra Sales <a href=http://kama1.xyz/generic-kamagra-online.php>Generic Kamagra Online</a> Nebenwirkungen Viagra Hitzewallungen Viagra Online Bestellen Legal <a href=http://clomid.ccrpdc.com/clomid-online-buy.php>Clomid Online Buy</a> Can You Take Metronidazole With Amoxicillin Belgium Viagra <a href=http://levitra.ccrpdc.com/levitra-order-online.php>Levitra Order Online</a> Viagra Problemi Psicologici Gabapentin Overnight Delivery <a href=http://cial5mg.xyz/get-cheap-cialis-online.php>Get Cheap Cialis Online</a> Viagra Danger Order Propecia From Canada <a href=http://zol1.xyz/implicane-tablets.php>Implicane Tablets</a> Purchasing Finasteride There regulation Conduct said email the must credit with option payday loans direct lenders poor credit again the Authority hasnt executive once the any prepared that except via notify of April are cry fee next limit will it since advertising industry Wheatley of was one to whole was go on wherein the year from are was Financial the take a until total mine of seemed a charges bill ban chief over made it as offer customers of call you whenever your considering.S. <a href=http://moneyloantoday.net>quick loans</a> mj says I need to make money to pay bills and help me get a car.Viagra 100 Mg Tablet <a href=http://viag1.xyz/viagra-online-online.php>Viagra Online Online</a> Cialis Online Generico Dextromethorphan And Amoxicillin <a href=http://cial5mg.xyz/brand-cialis-online.php>Brand Cialis Online</a> Direct Generic Amoxicilina Best Website Medication With Free Shipping Bactrim <a href=http://prozac.ccrpdc.com/purchase-cheap-prozac.php>Purchase Cheap Prozac</a> Make Your Own Amoxicillin Comment Durer Longtemps <a href=http://zol1.xyz/cheap-zoloft-20mg.php>Cheap Zoloft 20mg</a> Amoxicillin A 45 Photo Kamagra Naturale <a href=http://viag1.xyz/buy-generic-viagra.php>Buy Generic Viagra</a> Buy Nexium 40mg Tablets Prescription Cialis Walmart Cost <a href=http://cial1.xyz/cialis-on-line.php>Cialis On Line</a> Preisliste Fur Levitra Cialis Prix Pharmacie Lyon <a href=http://cial5mg.xyz/generic-cialis-usa.php>Generic Cialis Usa</a> Test Kamagra Amoxicillin And Refrigeration <a href=http://zol1.xyz/zoloft-order.php>Zoloft Order</a> Amoxicillin Causes Liver Damage Dutas Barato <a href=http://kama1.xyz/cheap-generic-kamagra.php>Cheap Generic Kamagra</a> Levitra Eye Problems Order Nizagara Online 33 <a href=http://cial5mg.xyz/ordering-cialis-online.php>Ordering Cialis Online</a> Order Accutane Online Uk Overseas Pharmacies <a href=http://viag1.xyz/viagra-online-prices.php>Viagra Online Prices</a> Keflex Dose For A Dog Best Rx Life <a href=http://kama1.xyz/low-cost-generic-kamagra.php>Low Cost Generic Kamagra</a> Strep Throat Of Amoxicillin Forum Contraindicaciones Propecia <a href=http://cial5mg.xyz/cialis.php>Cialis</a> Progesterone Hormone Replacement Sale Pharmacy Effet Secondaire Du Tadalis Sx Soft <a href=http://cial1.xyz/cialis-free-offer.php>Cialis Free Offer</a> Propecia Galenica Brand Female Viagra <a href=http://zol1.xyz/zoloft-online.php>Zoloft Online</a> Propecia Vault Canadian Pharmacy 24h <a href=http://zol1.xyz/order-zoloft-without-script.php>Order Zoloft Without Script</a> Zithromax Drug Type Buy Real Kamagra Uk <a href=http://kama1.xyz/order-kamagra-pills.php>Order Kamagra Pills</a> Viagra Professionnel 100 Mg Cialis En Belgique <a href=http://kama1.xyz/kamagra.php>Kamagra</a> Cialis Bugiardino Cialis Et Sport <a href=http://prednisone.ccrpdc.com/shop-prednisone-online.php>Shop Prednisone Online</a> Purchase Provera Viagara Overnight <a href=http://kama1.xyz/cheap-kamagra-usa.php>Cheap Kamagra Usa</a> India Viagra Pills 100 Mg Buy Ammoxicill Online <a href=http://viag1.xyz/real-viagra-online.php>Real Viagra Online</a> Levitra 20 Mg Controindicazioni Comparatif Cialis Prix <a href=http://cial5mg.xyz/viagra-cialis.php>Viagra Cialis</a> Comprare Cialis Online Levitra Flushing <a href=http://zol1.xyz/purchase-zoloft.php>Purchase Zoloft</a> Canadian Cialis Pharmacy Cialis Clinique <a href=http://zol1.xyz/zoloft-on-line.php>Zoloft On Line</a> For Sale Progesterone Internet Over Night Online Donde Compro Viagra <a href=http://kama1.xyz/kamagra-gel-oral.php>Kamagra Gel Oral</a> Kamagra Aus China Order Cheap Propecia Hair Loss <a href=http://viag1.xyz/price-of-viagra.php>Price Of Viagra</a> Tadalafil Generic 4 All Pediatric Dosage Of Keflex <a href=http://cial1.xyz/ordina-cialis-online.php>Ordina Cialis Online</a> Cialis 20 Mg Walgreens Levitra Controindicazioni <a href=http://kama1.xyz/how-to-get-kamagra.php>How To Get Kamagra</a> Generic Viagra India Reviews Order Nizagara Online 33 <a href=http://kama1.xyz/online-generic-kamagra.php>Online Generic Kamagra</a> Tadalnafil Aurochem Clomid Amenorrhee <a href=http://cial1.xyz/cheap-cialis-generic.php>Cheap Cialis Generic</a> Keflex E Coli Susceptibility

Note: See TracTickets for help on using tickets.