Ticket #776 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

X crashes when terminal is closed with power button

Reported by: olaf@… Owned by: buglog@…
Priority: high Milestone:
Component: openmoko-terminal Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, andreas@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

console output:

(neod:2500): DEBUG: triggering power timer
(neod:2500): DEBUG: resetting power timer
(neod:2500): DEBUG: power pressed for 0
(neod:2500): DEBUG: mainmenu powersave reset
(neod:2500): DEBUG: mainmenu set display 100
(neod:2500): DEBUG: active Window = 18874373 ('(null)')
matchbox-keyboard-remote.c:34,mb_kbd_remote_process_xevents() got a message

run-parts: /etc/X11/Xsession.d/90xXWindowManager exited because of uncaught
signal 11: Success
FreeFontPath?: FPE "built-ins" refcount is 2, should be 1; fixing.
X connection to :0.0 broken (explicit kill or server shutdown).

Change History

comment:1 Changed 12 years ago by laforge@…

  • Cc andreas@… added

* Bug 738 has been marked as a duplicate of this bug. *

comment:2 Changed 12 years ago by alphaone@…

This doesn't seem to happen anymore with the new terminal. Olaf, could you
please confirm that a new build indeed seems to fix this?

comment:3 Changed 12 years ago by olaf@…

yes, it is fixed with the new terminal

comment:4 Changed 12 years ago by olaf@…

  • Status changed from new to closed
  • Resolution set to fixed

changed status to fixed

Note: See TracTickets for help on using tickets.