Ticket #784 (closed defect: invalid)

Opened 12 years ago

Last modified 2 years ago

webkit build fails

Reported by: mcl@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The webkit package fails to build.

The bitbake recipe at openembedded/packages/webkit/webkit-gtk_svn.bb had a
comment in the middle of the SRC_URI definition. This seemed to be stopping the
sources from being downloaded. I moved that comment outside of the def. and the
package started building again.

Can provide a diff if required.

Output from a failed build is copied below:

OE Build Configuration:
BB_VERSION = "1.8.8"
OE_REVISION = "4c108250ef95743112aee6c23a4f206124025bbb"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "fic-gta01"
DISTRO = "openmoko"
DISTRO_VERSION = "P1-August-Snapshot-20070901"
TARGET_FPU = "soft"

NOTE: Resolving missing task queue dependencies
NOTE: preferred version 2.5 of glibc not available (for item
virtual/arm-angstrom-linux-gnueabi-libc-for-gcc)
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 3080 of 3351 (ID: 1463,
/home/build/openmoko/om2007.2/openembedded/packages/webkit/webkit-gtk_svn.bb,
do_compile)
NOTE: package webkit-gtk-0.0+svn20070901: started
NOTE: package webkit-gtk-0.0+svn20070901-r1: task do_compile: started
ERROR: function do_compile failed
ERROR: log data follows
(/home/build/openmoko/om2007.2/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svn20070901-r1/temp/log.do_compile.12025)
|
/home/build/openmoko/om2007.2/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svn20070901-r1/temp/run.do_compile.12025:
line 218: cd:
/home/build/openmoko/om2007.2/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svn20070901-r1//JavaScriptCore/pcre:
No such file or directory
NOTE: Task failed:
/home/build/openmoko/om2007.2/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svn20070901-r1/temp/log.do_compile.12025
NOTE: package webkit-gtk-0.0+svn20070901-r1: task do_compile: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package webkit-gtk-0.0+svn20070901: failed
ERROR: Build of
/home/build/openmoko/om2007.2/openembedded/packages/webkit/webkit-gtk_svn.bb
do_compile failed
ERROR: Task 1463
(/home/build/openmoko/om2007.2/openembedded/packages/webkit/webkit-gtk_svn.bb,
do_compile) failed
NOTE: Tasks Summary: Attempted 3079 tasks of which 3079 didn't need to be rerun
and 1 failed.
ERROR:
'/home/build/openmoko/om2007.2/openembedded/packages/webkit/webkit-gtk_svn.bb'
failed
make: * [openmoko-devel-image] Error 1

Attachments

log.do_compile.19111 (3.8 KB) - added by Nad.Oby@… 12 years ago.
There is new issue in webkit failing to build

Change History

Changed 12 years ago by Nad.Oby@…

There is new issue in webkit failing to build

comment:1 Changed 12 years ago by Nad.Oby@…

  • attachments.mimetype changed from application/octet-stream to text/plain

comment:2 Changed 12 years ago by Nad.Oby@…

(From update of attachment 273)

NOTE: make MAKEFLAGS=
make[1]: Entering directory `/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug'
cd WebCore/? && make -f Makefile
make[2]: Entering directory `/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug/WebCore'
make[2]: Nothing to be done for `first'.
make[2]: Leaving directory `/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug/WebCore'
cd JavaScriptCore?/kjs/ && make -f Makefile.testkjs
make[2]: Entering directory `/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug/JavaScriptCore/kjs'
ccache arm-angstrom-linux-gnueabi-g++ -march=armv4t -mtune=arm920t -L/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib -Wl,-rpath-link,/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib -Wl,-O1 -Wl,-rpath-link,/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/qt4/lib -Wl,-rpath-link,/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug/lib -o ../testkjs testkjs.o pcre_get.o pcre_refcount.o pcre_ucp_findchar.o pcre_compile.o pcre_globals.o pcre_config.o pcre_version.o pcre_info.o pcre_study.o pcre_exec.o pcre_xclass.o pcre_tables.o pcre_maketables.o pcre_try_flipped.o pcre_ord2utf8.o pcre_fullinfo.o TCSystemAlloc.o Assertions.o HashTable?.o FastMalloc?.o NP_jsobject.o npruntime.o runtime_array.o runtime.o runtime_method.o runtime_object.o runtime_root.o c_class.o c_instance.o c_runtime.o c_utility.o DateMath?.o JSWrapperObject.o PropertyNameArray?.o array_object.o bool_object.o collector.o CommonIdentifiers?.o Context.o date_object.o debugger.o dtoa.o error_object.o ExecState?.o fpconst.o function.o function_object.o identifier.o internal.o interpreter.o JSImmediate.o JSLock.o lexer.o list.o lookup.o math_object.o nodes.o nodes2string.o number_object.o object.o object_object.o operations.o Parser.o property_map.o property_slot.o regexp.o regexp_object.o scope_chain.o string_object.o ustring.o value.o grammar.o -L/home/moko/build/tmp/staging/i686-linux/lib -Wl,-rpath-link,/home/moko/build/tmp/staging/i686-linux/lib -Wl,-rpath,/home/moko/build/tmp/staging/i686-linux/lib -Wl,-O1 -licui18n -licuuc -licudata -lpthread -lm
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `operator delete(void*)@GLIBCXX_3.4'
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `vtable for cxxabiv1::class_type_info@CXXABI_1.3'
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `gxx_personality_v0@CXXABI_1.3'
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `
cxa_end_cleanup@CXXABI_1.3'
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `vtable for cxxabiv1::si_class_type_info@CXXABI_1.3'
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `vtable for cxxabiv1::vmi_class_type_info@CXXABI_1.3'
/home/moko/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/libicui18n.so: undefined reference to `cxa_pure_virtual@CXXABI_1.3'
collect2: ld returned 1 exit status
make[2]: * testkjs Error 1
make[2]: Leaving directory `/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug/JavaScriptCore/kjs'
make[1]:
* [sub-JavaScriptCore?-kjs-testkjs-pro-make_default-ordered] Error 2
make[1]: Leaving directory `/home/moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/webkit-gtk-0.0+svnrwebcore-rwebkit-r1/WebKitBuilds/Debug'
FATAL: oe_runmake failed

comment:3 Changed 12 years ago by mcl@…

  • Status changed from new to closed
  • Resolution set to invalid

This turned-out to be an issue with the build-tree. "touch"ing the bitbake
recipe file (e.g. openembedded/packages/webkit/webkit-gtk_svn.bb) solved the
problem for this and other packages, as well as doing make
clean-package-<package> for failing packages.

comment:4 Changed 2 years ago by JustDox

Us Purchasing Of Furosemide <a href=http://kama1.xyz/buy-kamagra-oral-jelly.php>Buy Kamagra Oral Jelly</a> Propecia E Impotencia Causar 120 Mg Di Sildenafil Vendita <a href=http://zol1.xyz/low-price-zoloft.php>Low Price Zoloft</a> Pleasure Cheap Viagra Pharm Suppoet Group Canada <a href=http://zol1.xyz/buy-cheap-zoloft-site.php>Buy Cheap Zoloft Site</a> Viagra Livraison Discrete Levitra Genericos <a href=http://kama1.xyz/cheap-kamagra-generic.php>Cheap Kamagra Generic</a> Viagra Und Co Kaufen Cheap Synthroid Online No Prescription <a href=http://kama1.xyz/kamagra-jelly-usa.php>Kamagra Jelly Usa</a> How To Last Longer During Mutuabile Vendita Propecia <a href=http://kama1.xyz/order-generic-kamagra.php>Order Generic Kamagra</a> Purple Viagra Pills Viagra Generico Pagamento Postepay <a href=http://prednisone.ccrpdc.com/generic-prednisone.php>Generic Prednisone</a> Viagra Order Online Usa Cialis Hace Dano <a href=http://cial1.xyz/order-cialis-in-usa.php>Order Cialis In Usa</a> Viagra Generic Vs Brand Propecia Sildenafil <a href=http://kama1.xyz/prices-kamagra.php>Prices Kamagra</a> Pastilla Cialis Alcohol Levitra Bayer France <a href=http://cial5mg.xyz/buy-tadalafil.php>Buy Tadalafil</a> Amoxil Chew Tabs Recall Keflex Lyme <a href=http://viag1.xyz/viagra-online-blue.php>Viagra Online Blue</a> Xenical A Petit Prix El Cialis Es Malo <a href=http://zol1.xyz/cheapest-zoloft-online.php>Cheapest Zoloft Online</a> Cheap Keflex Allergic Itching Due To Amoxicillin <a href=http://cial1.xyz/cialis-prices.php>Cialis Prices</a> Cialis Et Jus De Pamplemousse Refill Prednisone <a href=http://cial1.xyz/female-cialis.php>Female Cialis</a> Viagra Kaufen Gegen Rechnung Contraindications Of Zithromax <a href=http://lasix.ccrpdc.com/how-to-get-lasix.php>How To Get Lasix</a> Fast Shipping Birth Control Pill Amoxicillin And Neurontin <a href=http://zol1.xyz/zoloft-to-buy.php>Zoloft To Buy</a> Find Stendra 50mg No Doctors Consult Overseas Hydrochlorothiazide Medicine Overseas Plymouth <a href=http://kama1.xyz/cheap-kamagra-pills.php>Cheap Kamagra Pills</a> Keflex 500 Mc Capsules Cialis On Line Melbourne Vic Fast Del <a href=http://clomid.ccrpdc.com/buy-clomiphene-online.php>Buy Clomiphene Online</a> Purchasing Discount Zentel In Internet With Free Shipping Order Birth Control Online <a href=http://cial1.xyz/buy-cialis.php>Buy Cialis</a> Sont Amoxil Buy Genuine Levitra <a href=http://inderal.ccrpdc.com/inderal-cost.php>Inderal Cost</a> Cialis Hemorragie Buy Thyroxine Uk <a href=http://viag1.xyz/purchase-viagra.php>Purchase Viagra</a> Parmacies On Line Cialis Overnight Fedex <a href=http://zithromax.ccrpdc.com/buy-cheap-zithromax.php>Buy Cheap Zithromax</a> Priligy Authentique Achat Pilule Viagra En Antibes <a href=http://viag1.xyz/cheap-viagra-fast.php>Cheap Viagra Fast</a> Silagra Uk Websites Generique Sildenafil 50 Mg <a href=http://cytotec.ccrpdc.com/order-cytotec-in-usa.php>Order Cytotec In Usa</a> Online Generic Viagra Paroxetina Receta <a href=http://kama1.xyz/kamagra-online-pharmacy.php>Kamagra Online Pharmacy</a> Viagra Rezeptfrei Ausland Propecia Online Order <a href=http://viag1.xyz/purchase-viagra.php>Purchase Viagra</a> Posologia Propecia Dia Viagra Pagine Sanitarie <a href=http://viagra.ccrpdc.com/viagra-for-sale.php>Viagra For Sale</a> Cialis Originale Al Miglior Prezzo Valrex <a href=http://zol1.xyz/generic-zoloft.php>Generic Zoloft</a> Amoxicilina Medicine Website Shop Without Rx Propecia Y Cerveza <a href=http://zol1.xyz/where-to-buy-zoloft.php>Where To Buy Zoloft</a> Viagra Vegetale It Viagra Libre Belgique <a href=http://cial1.xyz/purchase-generic-cialis.php>Purchase Generic Cialis</a> Zithromax Free At Publix Brescia Vendo Cialis <a href=http://cial1.xyz/buy-online-cialis.php>Buy Online Cialis</a> Amoxicillin Improvement Noticed In Bowel Bacteria Cialis Belgique Ordonnance <a href=http://kama1.xyz/buy-cheap-kamagra.php>Buy Cheap Kamagra</a> Isotretinoin Where Can I Buy Vidal Tamoxifene <a href=http://cial5mg.xyz/how-to-order-cialis.php>How To Order Cialis</a> Propecia Mental Side Effects

Note: See TracTickets for help on using tickets.