Ticket #789 (closed defect: worksforme)

Opened 12 years ago

Last modified 11 years ago

Occasional phone crash on X startup

Reported by: fabchevalier@… Owned by: willie_chen@…
Priority: high Milestone:
Component: kernel Version: current svn head
Severity: critical Keywords: VERIFIED
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Hi,

For an unknown reason, my Neo would occasionally crash during X startup (either
after phone reboot, or after manual X server restart).
The only way to reboot the phone is to to a long press on the power key, or to
remove the battery.

The issue is not systematic, but I get the issue once every 4 to 5 times i start
the X server.

I have no idea how i can provide more precise information, if there is anything
i can do to help just let me know ;-)

Kernel and root image have just been rebuilt from head SVN and head mtn
repositories.

regards,

Fabien

Change History

comment:1 Changed 12 years ago by roh@…

  • Status changed from new to closed
  • Resolution set to duplicate

triggered by gsmd restart via xsession

* This bug has been marked as a duplicate of 788 *

comment:2 Changed 12 years ago by fabchevalier@…

  • Status changed from closed to reopened
  • Resolution duplicate deleted

Any proof of that ?

I just retried with the stty workaround for #788 applied.
... and i just crashed my phone on X startup... again !!

It looks like another issue to me...

Fabien

comment:3 Changed 12 years ago by laforge@…

this bug is unlikely to ever get resolved or even further analyzed without more
details. Please provide at least the program counter at the time of the crash
(by using JTAG).

comment:4 Changed 11 years ago by mickey@…

Can you still reproduce this with a fresh kernel built from OE?

comment:5 Changed 11 years ago by willie_chen@…

  • Owner changed from laforge@… to willie_chen@…
  • Status changed from reopened to new

comment:6 Changed 11 years ago by andy@…

  • Status changed from new to closed
  • Resolution set to worksforme

Going to close as WORKSFORME since there is no reproduction or further info
since 3 months, and there is nothing we can do with what we have.

comment:7 Changed 11 years ago by fabchevalier@…

  • Keywords VERIFIED added

Haven't managed to reproduce it for a while, it looks this bug has vanished :-)

Note: See TracTickets for help on using tickets.