Ticket #801 (closed defect: wontfix)

Opened 12 years ago

Last modified 2 years ago

qemu-native fails to build on gentoo/gcc-3.4.6

Reported by: christoph.gysin@… Owned by: dodji@…
Priority: high Milestone:
Component: qemu-neo1973 Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

make openmoko-devel-image fails at qemu-native:

( cd build && . ../setup-env && \

bitbake openmoko-devel-image )

NOTE: Handling BitBake? files: | (4648/4648) [100 %]
NOTE: Parsing finished. 4421 cached, 0 parsed, 227 skipped, 0 masked.
NOTE: build 200709051611: started

OE Build Configuration:
BB_VERSION = "1.8.8"
OE_REVISION = "f187242e911a395651f8c0b903c471eaa5944ab9"
TARGET_ARCH = "arm"
TARGET_OS = "linux-gnueabi"
MACHINE = "fic-gta01"
DISTRO = "openmoko"
DISTRO_VERSION = "P1-August-Snapshot-20070905"
TARGET_FPU = "soft"

NOTE: Resolving missing task queue dependencies
NOTE: preferred version 2.5 of glibc not available (for item
virtual/arm-angstrom-linux-gnueabi-libc-for-gcc)
NOTE: Preparing runqueue
NOTE: Executing runqueue
NOTE: Running task 133 of 3321 (ID: 1144,
/home/fr33z3/openmoko/openembedded/packages/qemu/qemu-native_20070613.bb,
do_compile)
NOTE: package qemu-native-0.9.0+cvs20070613: started
NOTE: package qemu-native-0.9.0+cvs20070613-r5: task do_compile: started
ERROR: function do_compile failed
ERROR: log data follows
(/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/temp/log.do_compile.28368)
| NOTE: make
| make[1]: Entering directory
`/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu'
| make -C i386-linux-user all
| make[2]: Entering directory
`/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/i386-linux-user'
| gcc-3.4.6 -Wall -O2 -g -fno-strict-aliasing -fno-reorder-blocks -fno-gcse

-fno-optimize-sibling-calls -fno-crossjumping -fno-align-labels

-fno-align-jumps -fno-align-functions -mpreferred-stack-boundary=2
-fomit-frame-pointer -I. -I..
-I/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386
-I/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu
-I/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/linux-user
-I/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/linux-user/i386
-D_GNU_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
-I/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/fpu
-DHAS_AUDIO -DHAS_AUDIO_CHOICE
-I/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/slirp
-c -o op.o
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386/op.c
|
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386/ops_sse.h:
In function `op_psrlq_mmx':
|
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386/ops_sse.h:213:
error: unable to find a register to spill in class `GENERAL_REGS'
|
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386/ops_sse.h:213:
error: this is the insn:
| (insn:HI 36 35 37 3
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386/ops_sse.h:207
(parallel [
| (set (reg:DI 63 [ <variable>.q ])
| (lshiftrt:DI (reg:DI 63 [ <variable>.q ])
| (subreg:QI (reg/v:SI 60 [ shift ]) 0)))
| (clobber (scratch:SI))
| (clobber (reg:CC 17 flags))
| ]) 309 {lshrdi3_1} (insn_list 33 (insn_list 35 (nil)))
| (expr_list:REG_DEAD (reg/v:SI 60 [ shift ])
| (expr_list:REG_UNUSED (reg:CC 17 flags)
| (expr_list:REG_UNUSED (scratch:SI)
| (nil)))))
|
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/target-i386/ops_sse.h:213:
confused by earlier errors, bailing out
| make[2]: * [op.o] Error 1
| make[2]: Leaving directory
`/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu/i386-linux-user'
| make[1]:
* [subdir-i386-linux-user] Error 2
| make[1]: Leaving directory
`/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/qemu'
| FATAL: oe_runmake failed
NOTE: Task failed:
/home/fr33z3/openmoko/build/tmp/work/i686-linux/qemu-native-0.9.0+cvs20070613-r5/temp/log.do_compile.28368
NOTE: package qemu-native-0.9.0+cvs20070613-r5: task do_compile: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package qemu-native-0.9.0+cvs20070613: failed
ERROR: Build of
/home/fr33z3/openmoko/openembedded/packages/qemu/qemu-native_20070613.bb
do_compile failed
ERROR: Task 1144
(/home/fr33z3/openmoko/openembedded/packages/qemu/qemu-native_20070613.bb,
do_compile) failed
NOTE: Tasks Summary: Attempted 132 tasks of which 132 didn't need to be rerun
and 1 failed.
ERROR:
'/home/fr33z3/openmoko/openembedded/packages/qemu/qemu-native_20070613.bb' failed
make: * [openmoko-devel-image] Error 1

Searching google brings up loads of people with problems compiling with gcc-4,
but this is gcc-3.4.6 failing!

There was a post on openmoko-devel by Jeff about the exact same problem:
http://lists.openmoko.org/pipermail/openmoko-devel/2007-August/001359.html

Is this a gcc bug?

Change History

comment:1 Changed 12 years ago by mickey@…

That looks like a bug in your native toolchain. I'm afraid there's not much we
can do about that.

comment:2 Changed 11 years ago by john_lee@…

  • Status changed from new to closed
  • Resolution set to wontfix

won't fix.

comment:3 Changed 2 years ago by Kennescoma

Which did you here about us.Others who testified against the bill includeKathy Jorgensen who said sheworks with the poor and marginalized at the Society of St. <a href=http://yourcashloan365.com>loans no credit check</a> Motherfucker Yalson heard herself say and she started running up the platform enfilading the front of the train trying to widen the angle of fire.Your Email Some unsecured business financing facilities and lenders offer what is called merchant account financing.Other rates.Levitra Shipped From Us <a href=http://kama1.xyz/cheap-kamagra-generic.php>Cheap Kamagra Generic</a> Progesterone Online Best Website Truro Propecia Ahnlich <a href=http://kama1.xyz/kamagra-online-pharmacy.php>Kamagra Online Pharmacy</a> Viagra En Vente best buy isotretinoin without a script North Dakota <a href=http://cial1.xyz/cialis-online-buy.php>Cialis Online Buy</a> Pneumonia And Amoxicillin Buying Propecia Propecia <a href=http://kama1.xyz/buy-kamagra-online.php>Buy Kamagra Online</a> Amoxicillin 93 3107 Buy Pfizer Viagra Pills Australia <a href=http://zol1.xyz/zoloft-free-trial.php>Zoloft Free Trial</a> Order Zoloft Without Script Cialis Prezzo Ufficiale <a href=http://accutane.ccrpdc.com/purchase-accutane-online.php>Purchase Accutane Online</a> Amoxicillin Dairy Milk Buy Nexium In Mexico <a href=http://prednisone.ccrpdc.com/order-prednisone-online.php>Order Prednisone Online</a> Comprar Cialis Con Paypal Keflex And Lung Infections <a href=http://cial1.xyz/cialis.php>Cialis</a> Secure Tab Doryx In Internet Shipped Ups Free Doctor Consultation How Do Guys Last Longer <a href=http://clomid.ccrpdc.com/clomiphene-online.php>Clomiphene Online</a> Need To Order Levothyroxine 125 Mcg Discount Generic Cialis <a href=http://zol1.xyz/order-zoloft-online-usa.php>Order Zoloft Online Usa</a> Kamagra Recensione Online Acquisto Cialis Svizzera <a href=http://cial1.xyz/generic-cialis-usa.php>Generic Cialis Usa</a> Finasteride Find Buy Cipro From India <a href=http://kamagra.ccrpdc.com/purchase-kamagra.php>Purchase Kamagra</a> Cheap Eurovan Zopiclone Composition Du Viagra Aux Herbes <a href=http://doxycycline.ccrpdc.com/doxycycline-online.php>Doxycycline Online</a> Generic Drugs Cheap Ed Pills <a href=http://kama1.xyz/buy-generic-kamagra.php>Buy Generic Kamagra</a> Priligy Test Keflex Children <a href=http://cial1.xyz/cheap-cialis.php>Cheap Cialis</a> Cheap Flovent Need Generic Worldwide Provera C.O.D. <a href=http://cial5mg.xyz/best-cialis-online.php>Best Cialis Online</a> Ca Based Viagra Supply Cialis 20 Mg Commenti <a href=http://viag1.xyz/cheap-viagra-pill.php>Cheap Viagra Pill</a> How To Compound Amoxicillin Suspension What Does Zithromax Look Like <a href=http://cial1.xyz/brand-cialis.php>Brand Cialis</a> Cialis Sans Ordonnance France Baclofene 10mg <a href=http://viag1.xyz/buy-cheap-viagra.php>Buy Cheap Viagra</a> Je Voulez Durer Plus Longtemps buy accutane in usa <a href=http://cialis.ccrpdc.com/cialis-price.php>Cialis Price</a> Levitra 10 Mgptt Buy Viagra Canadian No Prescription <a href=http://zoloft.ccrpdc.com/zoloft-online.php>Zoloft Online</a> Purchase Free Shipping Elocon Price Free Doctor Consultation Mastercard Viagra Site Belge <a href=http://kamagra.ccrpdc.com/cheapest-kamagra.php>Cheapest Kamagra</a> Viagra Generico Contrareembolso Espana Comprar Cialis Priligy <a href=http://cial1.xyz/generic-for-cialis.php>Generic For Cialis</a> Online Lasix Generic Tadalis Sx Pas Cher <a href=http://viag1.xyz/viagra-discount-sales.php>Viagra Discount Sales</a> Amoxicillin For Fish Zithromax For Rabbits <a href=http://viag1.xyz/low-price-viagra.php>Low Price Viagra</a> Achat Cialis Meilleur Prix Cherche Viagra Suisse <a href=http://antabuse.ccrpdc.com/order-antabuse.php>Order Antabuse</a> Sample Tadalis Sx Soft Cialis Griechenland Rezeptpflichtig <a href=http://zol1.xyz/where-to-buy-zoloft.php>Where To Buy Zoloft</a> Does Amoxicillin In Pill Form Expire Finasteride 1 G Propecia <a href=http://clomid.ccrpdc.com/generic-clomid-pills.php>Generic Clomid Pills</a> Amoxicillin 400 Mg Adult Dose Cialis Achat Belgique <a href=http://zol1.xyz/cheap-zoloft-no-rx.php>Cheap Zoloft No Rx</a> Order Nizagara Online Buy Retin A Uk <a href=http://zol1.xyz/implicane.php>Implicane</a> Acheter Sildenafil 50 Mg Naproxen And Amoxicillin Allergy <a href=http://cial5mg.xyz/cialis-online-pharmacy.php>Cialis Online Pharmacy</a> Cialis Im Urlaub Kaufen Priligy Sin Receta Mexico <a href=http://zol1.xyz/buy-zoloft-online.php>Buy Zoloft Online</a> Kamagra Jelly 100mg Toulouse Lybrel Birth Control No Persciption <a href=http://cial1.xyz>Buy Cialis</a> Side Effects To Cephalexin Propecia Rabia <a href=http://levitra.ccrpdc.com/levitra-where-to-buy.php>Levitra Where To Buy</a> Acheter Levitra Comprime

Note: See TracTickets for help on using tickets.