Ticket #802 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

openmoko-dialer2 segfaults when first digit entered is '#'

Reported by: cwixon@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-dialer Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, cw@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Version is 0.1.0+svnr2869-r5

I can enter numeric digits (and dial) successfully.

But to check my GSM account balance I need to dial #999#, and it crashes
(segfault, according to the terminal) as soon as I hit that first '#'.

Attachments

05_fix_crash_bug_802.patch (400 bytes) - added by roman.moravcik@… 12 years ago.
[PATCH] 5/5 Fix segfaults whne first digit entered is '#'
05_fix_crash_bug_802_2.patch (532 bytes) - added by roman.moravcik@… 12 years ago.
[PATCH] 5/5 Fix segfaults whne first digit entered is '#' (2)

Change History

comment:1 Changed 12 years ago by cw@…

  • Cc cw@… added

0.1.0+svnr2869-r5 works here and doesn't crash for me (i don't get the network
information back, but i can see it in the logs)

perhaps (when you get a chance) can you update and retest this and verify it
still crashes for you?

comment:2 Changed 12 years ago by cwixon@…

It's very repeatable, even immediately after a reboot.

Unfortunately I don't see any logs that might shed more light on the situation.

All I get on the terminal display -- if I happened to have restarted

openmoko-dialer from there -- is the segfault message. And I should add,
sometimes it takes other things down with it, such as the Window Manager.

I have seen a lot of check-ins on the dialer lately, so I'll verify again after
I'm able to upgrade it. (I haven't been able to complete a build in the last
couple of days, I think because of ${SRCREV} gremlins.)

comment:3 Changed 12 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

I committed several fixes which have meant I am no longer able to reproduce this
bug. Please re-open if you can still reproduce this bug with the latest version
of the software.

comment:4 Changed 12 years ago by cwixon@…

  • Keywords VERIFIED added

Works for me now. Thanks, nice job.

comment:5 Changed 12 years ago by roman.moravcik@…

  • Status changed from closed to reopened
  • Keywords VERIFIED removed
  • Resolution fixed deleted

After i've got dialer history working, I can reproduce this segfault.

comment:6 Changed 12 years ago by thomas@…

The digits array is defined as having 11 elements, so accessing the 12th element
is not going to be a good idea. I think moko_contacts_fuzzy_lookup() should
probably just return NULL if it can't convert the character to a digit.

Changed 12 years ago by roman.moravcik@…

[PATCH] 5/5 Fix segfaults whne first digit entered is '#' (2)

comment:7 Changed 12 years ago by roman.moravcik@…

  • attachments.isobsolete changed from 0 to 1

comment:8 Changed 12 years ago by thomas@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Patch comitted (r3085), thanks.

Note: See TracTickets for help on using tickets.