Ticket #806 (closed defect: invalid)

Opened 11 years ago

Last modified 19 months ago

Standby voltage set to 2.1V, not 1.8V as datasheet says.

Reported by: speedevil@… Owned by: openmoko-kernel
Priority: high Milestone:
Component: PMU (Power Management Unit) Version: GTA01v4
Severity: normal Keywords:
Cc: buglog@…, andy@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

The set voltage on d3reg is 2.1V.
The SoC datasheet seems to indicate 1.8V is correct.

Change History

comment:1 Changed 11 years ago by mickey@…

Any comments, Sean?

comment:2 Changed 11 years ago by tick@…

  • Owner changed from sean_chiang@… to willie_chen@…

comment:3 Changed 11 years ago by andy@…

  • Status changed from new to assigned
  • blocked set to 458

Setting as blocker for the standby power parent #458
Needs to be checked on current rev kernel on GTA-02 to see if it is still an
issue, because it will impact standby consumption quite badly.

comment:4 Changed 11 years ago by reddog@…

Where in the datasheet did you find this?
And from where do you know that voltage on d3reg is 2.1V?
What is d3reg?

comment:5 Changed 11 years ago by reddog@…

Ok, found it!
But why u-boot set d3reg to 2.1V?

comment:6 Changed 11 years ago by laforge@…

GTA01 should run fine on 1.8V, shouldn't it?

Only GTA02 has some relation with 2.1V, depending on the CPU type.

comment:7 Changed 11 years ago by laforge@…

I'm sorry. IT is correct. All publicly released GTA01 revisions have a 266MHz
CPU. Depending on the CPU clock, the voltage has to vary.

VDDi is specified at 2.0V +/- 0.1V at 266MHz
VDDi is specified at 1.8V +/- 0.15V at 200MHz

since the PMU can only be tuned in 200mV steps, 2.0V is not an option, but we
have to use 2.1V.

Cheers,

comment:8 Changed 11 years ago by speedevil@…

Sorry about the delays - the bugzilla mail was getting sent to the wrong mailbox.

It looks like I was partially mistaken - I hadn't found a spec for vddalive, so
ignored it and simply looked at the vddrtc rating - which explicitly says 2.1v
isn't allowed.

Where I got the information from was
http://www.samsung.com/global/business/semiconductor/productRightMenuDown.do?doc_file=26537

On page 487, table 24-2 Recommended Operating Conditions

I think the initial problem is that the wiki page says

STBY_1V8

  • Standby Voltage for S3C2410
  • Generated by PMU D3REG
  • Used by

o S3C2410 (vddalive/rtc)

On that table, Vddrtc is clearly stated as 1.8V+-0.15 at both speeds.
The datasheet never actually specifies as I can see it a voltage for VDDalive,
it merely implies it as notes on clock timing constraints.

2.1V is actually a bit above the recommended maximum of 1.95 of VDDrtc, so
operation is not guaranteed.
As the absolute maximum is 2.7V, damage will almost certainly not occur.

(the PMU supply in question has a granularity of 300mv as I understand it, as
indicated by your other calcs - typo I assume)

The 'right' thing to do would seem to be to on shutdown go to 200Mhz mode first,
then off.
This is at best a small power saving, 40uA at most.
Or to put another way will decrease standby in RAM time (with GSM and everything
else off by some 10%)

comment:9 Changed 11 years ago by andy@…

  • Cc andy@… added

comment:10 Changed 10 years ago by roh

  • Owner changed from willie_chen@… to willie_chen

comment:11 Changed 10 years ago by john_lee

  • Owner changed from willie_chen to openmoko-kernel
  • HasPatchForReview unset

willie_chen doesn't work for us anymore. Reassign to openmoko-kernel.

comment:12 Changed 10 years ago by andy

  • Status changed from assigned to closed
  • Resolution set to invalid

If I understood what Harald last wrote, this isn't a real problem.

comment:13 Changed 19 months ago by RoberMync

Viagra Alcool Tabac <a href=http://cial5mg.xyz/order-generic-cialis.php>Order Generic Cialis</a> Propecia Usos Priligy Generico Vendita Italia <a href=http://zol1.xyz/buy-zoloft-uk.php>Buy Zoloft Uk</a> Cheapest Nonprescription Bactrim Amoxicillin Sexual Dysfunction <a href=http://kama1.xyz/kamagra-online-buy.php>Kamagra Online Buy</a> Lasaoren Suche Viagra Ch <a href=http://antabuse.ccrpdc.com/antabuse-order-online.php>Antabuse Order Online</a> Buy Tadacip Canada Contact Rayhhealthcare <a href=http://zol1.xyz/zoloft-online.php>Zoloft Online</a> 60 Mg Cialis Canadian Pharmacy Clomid Accident Fausse Couche <a href=http://viag1.xyz/order-viagra-online.php>Order Viagra Online</a> Costo Cialis 10 Mg Tab Shipped Ups Progesterone Amex Accepted Store <a href=http://zol1.xyz/cost-of-zoloft.php>Cost Of Zoloft</a> Kamagra Jelly Wirkung

Note: See TracTickets for help on using tickets.