Ticket #835 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

MokoSearchBar has wrong size

Reported by: hrw@… Owned by: thomas@…
Priority: high Milestone:
Component: Theming - Gtk+ Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Contacts use MokoSearchBar? to filter list of entries. But when filtering is
open then icon has other height then text entry field.

Attachments

a0607d736c4eda44b6f9a0131f730881.png (22.7 KB) - added by hrw@… 12 years ago.
Example screenshot
f3e1a5891f06f0f5947f092483ebac33.png (41.2 KB) - added by hrw@… 11 years ago.
screenshot with new Moko theme

Change History

Changed 12 years ago by hrw@…

Example screenshot

Changed 11 years ago by hrw@…

screenshot with new Moko theme

comment:1 Changed 11 years ago by thomas@…

Unfortunately this is because GTK+ always uses the font size when drawing the
entry widgets.

comment:2 Changed 11 years ago by hrw@…

Can font size be bumped so text input will fill all available space?

comment:3 Changed 11 years ago by nod_huang@…

  • Owner changed from buglog@… to chris@…

comment:4 Changed 11 years ago by thomas@…

  • Owner changed from chris@… to thomas@…

comment:5 Changed 11 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

I've bumped up the padding so that it fixes this issue. It will need to be
adjusted if the default font size changes however.

Note: See TracTickets for help on using tickets.