Ticket #839 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Call history does not work

Reported by: hrw@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-dialer Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I made outgoing, incoming, missed outgoing, missed incoming calls but none of
them were added into history.

Attachments

openmoko-dialer_history_fix.patch (7.1 KB) - added by roman.moravcik@… 12 years ago.
call history fix
01_dialer_fixes.patch (1.2 KB) - added by roman.moravcik@… 12 years ago.
[PATCH] 1/5 Moko journal fixes
02_add_gsm_location.patch (1.6 KB) - added by roman.moravcik@… 12 years ago.
[PATCH] 2/5 Store network information
03_history_fixes.patch (2.2 KB) - added by roman.moravcik@… 12 years ago.
[PATCH] 3/5 Dialer history fixes
04_contacts_fixes.patch (2.1 KB) - added by roman.moravcik@… 12 years ago.
[PATCH] 4/5 Fix loading of contact phone numbers
04_contacts_fixes_2.patch (2.3 KB) - added by roman.moravcik@… 12 years ago.
[PATCH] 4/5 Fix loading of contact phone numbers (2)

Change History

comment:1 Changed 12 years ago by thomas@…

Thanks for your patch. Could you separate the different changes in it please? If
possible, one patch per feature or bug fix would be very useful.

comment:2 Changed 12 years ago by roman.moravcik@…

Ok, I split it to 5 patches. The last one is attached to #802,
because that patch looks like is a rated to that issue.

Changed 12 years ago by roman.moravcik@…

call history fix

comment:3 Changed 12 years ago by roman.moravcik@…

  • attachments.isobsolete changed from 0 to 1

Changed 12 years ago by roman.moravcik@…

[PATCH] 2/5 Store network information

Changed 12 years ago by roman.moravcik@…

[PATCH] 3/5 Dialer history fixes

comment:4 Changed 12 years ago by thomas@…

I have committed patches 1, 2 and 3. However, patch 4 appears to use a variable
'i' which uninitialised.

Changed 12 years ago by roman.moravcik@…

[PATCH] 4/5 Fix loading of contact phone numbers

comment:5 Changed 12 years ago by roman.moravcik@…

  • attachments.isobsolete changed from 0 to 1

comment:6 Changed 12 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

All patches now committed to SVN. Marking bug as FIXED.

Thanks for your patches!

comment:7 Changed 12 years ago by hrw@…

Call history works for me with recent dialer.

Note: See TracTickets for help on using tickets.