Ticket #845 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Dialer doesn't honour its button in Today

Reported by: Tuukka.Hastrup@… Owned by: chris@…
Priority: high Milestone:
Component: openmoko-today Version: current svn head
Severity: critical Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Whereas the button in Today for Contacts always works in my tests, the button
for Dialer does not. This leads me to suspect the bug is in Dialer although it
could be in Today as well.

Most often the button for dialer works the first time. But when I change back to
Today, the button doesn't bring the dialer up anymore. If I try tens of times,
at some point it does work however. Also if I close the existing window, I might
have more chance of success with the button after that.

Change History

comment:1 Changed 12 years ago by thomas@…

So the issue here is that the main Dialer window does not get presented if it is
already open, but hidden at the time the button is Today is pressed?

comment:2 Changed 12 years ago by Tuukka.Hastrup@…

Yes, that's one part of the issue.

The second part is that if the Dialer window is not open, it often doesn't open
at the time the button in Today is pressed.

comment:3 Changed 12 years ago by thomas@…

  • Owner changed from thomas@… to chris@…

comment:4 Changed 12 years ago by chris@…

This is probably due to the button launching dialer single-instance, when dialer
has its own single-instance handling. I'll look into this ASAP

comment:5 Changed 12 years ago by thomas@…

  • Component changed from openmoko-dialer to openmoko-today

Moving to openmoko-today component, as this problem only occurs from the Dialer
shortcut button on the home screen.

comment:6 Changed 11 years ago by chris@…

  • Status changed from new to closed
  • Resolution set to fixed

Fixed. Was due to single-instance launching and Dialer doing its own
single-instance handling, as hypothesised.

Note: See TracTickets for help on using tickets.