Ticket #858 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

Tasks should be unique application

Reported by: hrw@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-today Version: current svn head
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Currently Tasks does not check does it is running - new copy is started each
time.

Attachments

541666531a04420a7b9725e1e2b3923e.png (17.5 KB) - added by hrw@… 12 years ago.
screenshot

Change History

Changed 12 years ago by hrw@…

screenshot

comment:1 Changed 12 years ago by mickey@…

  • Status changed from new to closed
  • Resolution set to fixed

today prevents multiple loading of applications now.

comment:2 Changed 11 years ago by hrw@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Tapping on tasks information on first tab of Today launch Tasks always.

comment:3 Changed 11 years ago by mickey@…

  • Component changed from openmoko-tasks to openmoko-today

This is a bug in today then, not in tasks.

comment:4 Changed 11 years ago by hrw@…

Hard to tell does it is Tasks or Today bug.

comment:5 Changed 11 years ago by nod_huang@…

  • Status changed from reopened to new
  • Owner changed from rob@… to thomas@…

comment:6 Changed 11 years ago by thomas@…

Marcin, it is a Today bug because we use Matchbox Single Instance checking to
implement single instance applications. The individual applications do not check
for single instance themselves.

comment:7 Changed 11 years ago by thomas@…

  • Status changed from new to closed
  • Resolution set to fixed

This seems to have been fixed recently. Please re-open if you still experience
this problem.

Note: See TracTickets for help on using tickets.