Ticket #863 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

Today should not close itself with all applications

Reported by: hrw@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-today Version: current svn head
Severity: critical Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

Today should close all applications EXCEPT itself when 'close all' action is
selected on 3rd tab.

Attachments

today_additional_checking.patch (741 bytes) - added by abraxa@… 12 years ago.
Proposed bugfix

Change History

comment:1 Changed 12 years ago by thomas@…

I cannot reproduce this with the latest version. Can you update and see if you
still experience this bug?

comment:2 Changed 12 years ago by hrw@…

I have r2693 today on device and this just happen again.

comment:3 Changed 12 years ago by chris@…

Today doesn't close itself, it crashes due to an X error - Unfortunately, I
don't know why this is yet, but it's on my TODO list to investigate and fix.

comment:4 Changed 12 years ago by abraxa@…

This is caused by a race condition that occurs when an application has already
received a close request and still gets enumerated in
today_task_manager_populate_tasks() to update the task list. When the function
then iterates over the enumerated windows the application might already have
finished shutting down, thereby making the window handle invalid.
For this reason, X reports a BadWindow? error on the gdk_window_get_type_hint()
call for such a window.

Proposed bugfix follows :)

-Soeren

Changed 12 years ago by abraxa@…

Proposed bugfix

comment:5 Changed 12 years ago by chris@…

  • Status changed from new to closed
  • Resolution set to fixed

Well done and thanks for the patch, committed in r3088

comment:6 Changed 12 years ago by hrw@…

looks like Today is not closing on my device anymore when I use 'close all
apps' button.

Note: See TracTickets for help on using tickets.