Ticket #871 (closed defect: duplicate)

Opened 12 years ago

Last modified 12 years ago

Application launcher categories don't work right

Reported by: cwixon@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-today Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

This is a pretty well-known and long-standing bug, I think, but I don't see it
in the tracker, so I am documenting it.

The application-launcher component of openmoko-today2 has several selectable
categories (Applications, All, Games, Utilities by default). Only Applications
and All seem to work correctly. For example, under "Applications," if you click
on "Calculator" you get the calculator.

All other categories *show* the correct items but do not behave correctly when
clicked. In fact, all other categories act as though "Applications" is selected.

So if "Bridges" is the second item under the Games category, when clicked it
will launch the calculator, because the calculator is the second item under the
Applications category.

Change History

comment:1 Changed 12 years ago by cwixon@…

  • Status changed from new to closed
  • Resolution set to duplicate

Duplicate of 861 -- which I couldn't find when I looked earlier.

* This bug has been marked as a duplicate of 861 *

Note: See TracTickets for help on using tickets.