Ticket #883 (closed defect: wontfix)

Opened 7 years ago

Last modified 5 years ago

Audible GSM interference when making a call

Reported by: hozer@… Owned by: tony_tu
Priority: high Milestone:
Component: Audio Version: GTA01v4
Severity: normal Keywords:
Cc: buglog@…, cw@… Blocked By:
Blocking: #1640 Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

When I am at home using an iwireless tower I get about 2 bars of signal.. (Is
there a better way to quantify the signal strenght?), and when I make a call, I
can hear GSM signal interference in the Neo earphone speaker.

I am running a self-built openmoko build from 2007-09-17.

Change History

comment:1 Changed 7 years ago by cw@…

  • Cc cw@… added

comment:2 Changed 7 years ago by hozer@…

I am now running the qtopia kernel & image, and I am seeing the same issue. It's
actually a T-Mobile tower with iWireless service, and when I am in a stairwell
at work with no bars of signal, I can hear the interference on the other end of
the call with a sprint treo 650.

The audible interference changes with orientation, and where my hand is placed,
so it appears that GSM RF signal is getting conducted by my hand to both the
microphone input and the speaker output.

In my office, with two bars of signal, the interference is only audible if it's
quiet (my macbook fan running full speed drowns it out), and only on the speaker
when both my head and hand are near the phone.

comment:3 Changed 6 years ago by tick@…

  • Owner changed from sean_chiang@… to willie_chen@…

comment:4 Changed 6 years ago by andy@…

  • Owner changed from willie_chen@… to tony@…

Reassigning to tony, since this is not a kernel issue for Willie but a
hardware one for GTA-01 it seems, GSM RF coupling to some high impedence audio
path, or it can be insufficient filtering on power? Are there changes like
lowpass or choke filtering to the analogue audio path or reduced GSM power
noise leaking back to other power on GTA-02?

comment:5 Changed 6 years ago by tony@…

  • Status changed from new to assigned

comment:6 Changed 6 years ago by roh

  • Owner changed from tony@… to tony_tu

comment:7 follow-up: ↓ 9 Changed 6 years ago by jjh

I have the same issue. I just received my Freerunner GTA02 this week and it appears that the feedback is there when the MicroSD card that came with my phone is installed. When I take the SD card out, the feedback is completely gone.

I have tried in various locations around my town and they all indicate that it is the SD card. I will be happy to try various experiments to help out.

comment:8 Changed 6 years ago by andy

Wow thanks for the report :-O

comment:9 in reply to: ↑ 7 Changed 6 years ago by hozer

Replying to jjh:

I have tried in various locations around my town and they all indicate that it is the SD card. I will be happy to try various experiments to help out.

Can you describe if and/or how the interference changes when you move your hand around? I'll try my GTA01 again without the SD card if it seems like it's the same thing. Do you have any easy way to call a number and record the call to record the interference?

comment:10 follow-up: ↓ 11 Changed 6 years ago by waffleIron

I'm having a similar problem with my Freerunner. The interference is mainly heard by the other person. I've noticed that if my fingers are touching the headphone jack, the gps port, or the usb port (in order from greatest to least effect) the interference gets worse. If I put my fingers flat on the back of the phone (from the battery to the lanyard hole) the interference drops off to almost nothing. This is all without the headset. With the headset in the noise is completely unbearable. Also, this is all without the SD card.

comment:11 in reply to: ↑ 10 Changed 6 years ago by kmsquire

I was inspired by the last poster, but following what he wrote didn't work exactly for me. However, I found that if I place my fingers only on the top and bottom of the phone (thumb on bottom, finger(s) on very top, not touching the back), the buzzing sound disappears. This appears to work consistently (for me), even with the SD card installed. (As above, headset is unusable, as is talking on speaker.)

comment:12 Changed 5 years ago by john_lee

  • Blocking 1640 added

comment:13 Changed 5 years ago by wendy_hung

  • Status changed from assigned to closed
  • HasPatchForReview unset
  • Resolution set to wontfix

this one is for GTA01, can't really reproduce this or test it.

Note: See TracTickets for help on using tickets.