Ticket #884 (closed defect: fixed)

Opened 12 years ago

Last modified 12 years ago

System doesn't support vfat filesystems on microSD cards

Reported by: gnu@… Owned by: laforge@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, gnu@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

The kernel isn't built with the vfat module (and fsck.vfat and such are neither
provided by default, nor available in an ipkg module). This means when you
stick in an SD card, it doesn't work. (You have to reformat it into ext3 or
something else, which non-interoperable with most other devices using SD and
microSD cards.)

Change History

comment:1 Changed 12 years ago by laforge@…

  • Status changed from new to closed
  • Component changed from kernel to OE bitbake recipes / build system
  • Resolution set to fixed

the kernel is built with the vfat module! The module is provided by the
kernel-module-vfat ipkg.

Or are you saying that this module should be part of the standard rootfs image?

comment:2 Changed 12 years ago by gnu@…

The kernel works for me now. My problem was that I'd updated with "ipkg update"
which breaks your kernel modules anytime someone updates the kernel.

comment:3 Changed 12 years ago by gnu@…

At Harald's request, I've logged the "kernel upgrade breaks modules" bug as #910.

Note: See TracTickets for help on using tickets.