Ticket #885 (closed defect: fixed)

Opened 12 years ago

Last modified 2 years ago

do_compile failure for gst-plugins-bad_0.10.5.bb

Reported by: mail@… Owned by: mickey@…
Priority: high Milestone:
Component: OE bitbake recipes / build system Version: 2007.2
Severity: normal Keywords:
Cc: buglog@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description

I am building with MokoMakefile?. I did an 'update-makefile' then a 'make setup
update openmoko-devel-image' earlier today, and the build failed here:

| ccache arm-angstrom-linux-gnueabi-gcc -march=armv4t -mtune=arm920t

-DHAVE_CONFIG_H -I. -I. -I../.. -isystem/myth/OpenMoko4/build/tmp
/staging/arm-angstrom-linux-gnueabi/include -I../../gst-libs -I../../gst-libs
-pthread -I/myth/OpenMoko4/build/tmp/staging/arm-angstrom
-linux-gnueabi/include/gstreamer-0.10
-I/myth/OpenMoko4/build/tmp/staging/arm-angstrom-linux-gnueabi/include/glib-2.0
-I/myth/OpenMoko4
/build/tmp/staging/arm-angstrom-linux-gnueabi/lib/glib-2.0/include
-I/myth/OpenMoko4/build/tmp/staging/arm-angstrom-linux-gnueabi/inclu
de/libxml2 -Wall -g -DGST_DISABLE_DEPRECATED
-isystem/myth/OpenMoko4/build/tmp/staging/arm-angstrom-linux-gnueabi/include
-fexpensive-o
ptimizations -fomit-frame-pointer -frename-registers -Os -MT
libgstcdaudio_la-gstcdaudio.lo -MD -MP -MF .deps/libgstcdaudio_la-gstcdaud
io.Tpo -c gstcdaudio.c -fPIC -DPIC -o .libs/libgstcdaudio_la-gstcdaudio.o
| gstcdaudio.c:25:21: error: cdaudio.h: No such file or directory
| gstcdaudio.c:54: error: field 'info' has incomplete type
| gstcdaudio.c:55: error: field 'volume' has incomplete type
| gstcdaudio.c: In function 'gst_cdaudio_change_state':
| gstcdaudio.c:293: warning: implicit declaration of function 'cd_init_device'
| gstcdaudio.c:299: warning: implicit declaration of function 'cd_close'
| gstcdaudio.c:302: warning: implicit declaration of function 'cd_stat'
| gstcdaudio.c:308: warning: implicit declaration of function 'cddb_discid'
| gstcdaudio.c:316: warning: implicit declaration of function 'cd_resume'
| gstcdaudio.c:318: warning: implicit declaration of function 'cd_play'
| gstcdaudio.c:335: warning: implicit declaration of function 'cd_pause'
| gstcdaudio.c:340: warning: implicit declaration of function 'cd_stop'
| gstcdaudio.c:342: warning: implicit declaration of function 'cd_finish'
| gstcdaudio.c: In function 'gst_cdaudio_send_event':
| gstcdaudio.c:425: warning: implicit declaration of function 'cd_play_pos'
| make[4]: * [libgstcdaudio_la-gstcdaudio.lo] Error 1
| make[4]: Leaving directory
`/myth/OpenMoko4/build/tmp/work/armv4t-angstrom-linux-gnueabi/gst-plugins-bad-0.10.5-r1/gst-plugins-bad-0.
10.5/ext/cdaudio'
| make[3]:
* [all-recursive] Error 1
| make[3]: Leaving directory
`/myth/OpenMoko4/build/tmp/work/armv4t-angstrom-linux-gnueabi/gst-plugins-bad-0.10.5-r1/gst-plugins-bad-0.
10.5/ext'
| make[2]: * [all-recursive] Error 1
| make[2]: Leaving directory
`/myth/OpenMoko4/build/tmp/work/armv4t-angstrom-linux-gnueabi/gst-plugins-bad-0.10.5-r1/gst-plugins-bad-0.
10.5'
| make[1]:
* [all] Error 2
| make[1]: Leaving directory
`/myth/OpenMoko4/build/tmp/work/armv4t-angstrom-linux-gnueabi/gst-plugins-bad-0.10.5-r1/gst-plugins-bad-0.
10.5'
| FATAL: oe_runmake failed
NOTE: Task failed:
/myth/OpenMoko4/build/tmp/work/armv4t-angstrom-linux-gnueabi/gst-plugins-bad-0.10.5-r1/temp/log.do_compile.5805
NOTE: package gst-plugins-bad-0.10.5-r1: task do_compile: failed
ERROR: TaskFailed? event exception, aborting
NOTE: package gst-plugins-bad-0.10.5: failed
ERROR: Build of
/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-bad_0.10.5.bb
do_compile failed
.bb, do_install)
NOTE: Running task 3250 of 3476 (ID: 3239,
/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-good_0.10.6.bb,
do_qa_configure)
NOTE: Running task 3251 of 3476 (ID: 3240,
/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-good_0.10.6.bb,
do_compile)
NOTE: Running task 3252 of 3476 (ID: 3244,
/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-good_0.10.6.bb,
do_install)
NOTE: Running task 3253 of 3476 (ID: 3229,
/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-bad_0.10.5.bb,
do_qa_configure)
NOTE: Running task 3254 of 3476 (ID: 3230,
/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-bad_0.10.5.bb,
do_compile)
ERROR: Task 3230
(/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-bad_0.10.5.bb,
do_compile) failed
NOTE: Tasks Summary: Attempted 3253 tasks of which 3025 didn't need to be rerun
and 1 failed.
ERROR:
'/myth/OpenMoko4/openembedded/packages/gstreamer/gst-plugins-bad_0.10.5.bb' failed
make: * [openmoko-devel-image] Error 1

The problem is repeatable after doing a 'make clean-package-gst-plugins-bad'.

I was able to work around the problem by removing the cdaudio packages from my
host system, then cleaning the package and re-running 'make openmoko-devel-image'.

Attachments

gst-plugins.inc-patch (537 bytes) - added by wandering.womble@… 12 years ago.
Patch to disable cdaudio
log.do_configure.30239 (34.7 KB) - added by mail@… 12 years ago.
do_configure log

Change History

comment:1 Changed 12 years ago by stefan@…

Still a problem? It builds fine for me.

comment:2 Changed 12 years ago by wandering.womble@…

I have the same problem (host is Gentoo.)

Changed 12 years ago by wandering.womble@…

Patch to disable cdaudio

comment:3 Changed 12 years ago by wandering.womble@…

Ok, trying to work through this (I'm new to OE...)

Looking in the tmp build directory:
moko/build/tmp/work/armv4t-angstrom-linux-gnueabi/gst-plugins-bad-0.10.5-r1/gst-plugins-bad-0.10.5

config.h:
/* support for features: cdaudio */
#define HAVE_CDAUDIO

Looks like a likely culprit.

Fiddling with moko/openembedded/packages/gstreamer/gst-plugins.inc and adding
--disable-cdaudio to EXTRA_OECONF seems to get this package to build via
make clean-package-gst-plugins-bad
make build-package-gst-plugins-bad

I've attached gst-plugins.inc-patch.

Julian

comment:4 Changed 12 years ago by stefan@…

It builds fine on a debian unstable and also a gentoo box here.

Do you have exactly the same error as the original poster?

Changed 12 years ago by mail@…

do_configure log

comment:5 Changed 12 years ago by mail@…

Still a problem - I just did a "make clean-package-gst-plugins-bad" and a "make
update", and got the same failure. I have attached the log.do_configure from
this attempt. The configure script is enabling the cdaudio plugin based on the
presence of the libcdaudio-dev package on the host system, but this package is
not present in the cross-compile environment when do_compile runs.

comment:6 Changed 12 years ago by stefan@…

Ah, now we came to the root of this problem. Disable the cdausio support is the
easy way to fix it, but I would like to know why it detects the host lib header
and is not able to use it.

I'll try to install the header on my debian system to test it out.

Thanks for your investigation so far.

comment:7 Changed 12 years ago by stefan@…

Confirmed. Same problem on my system with the package installed.

comment:8 Changed 12 years ago by stefan@…

  • Status changed from new to closed
  • Resolution set to fixed

I commited the patch into OpenEmbedded?. Revision
152391f4367c4184f3b73eb8fa296c0a57a369b5

Thanks for your contribution.

comment:9 Changed 12 years ago by wandering.womble@…

  • Status changed from closed to reopened
  • Resolution fixed deleted

Stefan- just did an update and noticed that the update has '-disable-cdaudio'
rather than '--disable-cdaudio' -- I'm guessing it's going to cause problems??

Julian

(PS- sorry, I did have the exact same problem as the original poster; but I
guess you know that by now ;-) )

comment:10 Changed 12 years ago by stefan@…

  • Status changed from reopened to closed
  • Resolution set to fixed

Thanks for spotting. I just pushed the fix.

It should have worked anyway. Seems that there is no difference in handling it
inside configure. I test my stuff before pushing. :)

comment:11 Changed 2 years ago by JustDox

Ok Pills Best <a href=http://kama1.xyz/kamagra.php>Kamagra</a> Cialis Apotheke Forum World Best Online Pharmacy Review <a href=http://viag1.xyz/viagra-online-cheap.php>Viagra Online Cheap</a> Balding Propecia Hair Loss Treatment Does Keflex Contain Penicillin <a href=http://cial1.xyz/canadian-cheap-cialis.php>Canadian Cheap Cialis</a> Viagra No Hace Efecto Usa Pharmacy Online Reviews <a href=http://cial1.xyz/buy-cialis-cheap.php>Buy Cialis Cheap</a> Approved Canadian Pharmacies Online Propecia For Sale Uk <a href=http://cial5mg.xyz/generic-cialis-usa.php>Generic Cialis Usa</a> Levitra 5mg Wirkung Where Can I Buy A Z Pack Online <a href=http://viag1.xyz/purchase-viagra-cheap.php>Purchase Viagra Cheap</a> Online Viagra Store Dieta Propecia <a href=http://viagra.ccrpdc.com/viagra-cheap.php>Viagra Cheap</a> Viagra Senza Ricetta Germania Using Amoxil For Cats <a href=http://cial1.xyz/generic-cialis-online.php>Generic Cialis Online</a> Cialis In Danemark Kaufen

Note: See TracTickets for help on using tickets.