Ticket #90 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

GSM TS07.10 multiplex missing

Reported by: laforge@… Owned by: sean_chiang@…
Priority: highest Milestone:
Component: gsmd Version: current svn head
Severity: critical Keywords:
Cc: buglog@…, cw@…, jserv@…, balrogg@…, wally.ritchie@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description


Attachments

0001-Introduce-ports.patch (16.7 KB) - added by balrogg@… 12 years ago.
Use struct gsmd_port instead of fd's.
0003-TS-07.10-multiplexing.patch (31.7 KB) - added by balrogg@… 12 years ago.
TS 07.10 multiplexing (incomplete).

Change History

comment:1 Changed 12 years ago by laforge@…

  • blocked set to 101

comment:2 Changed 12 years ago by laforge@…

  • Priority changed from high to highest

comment:3 Changed 12 years ago by laforge@…

  • Milestone set to Phase 0

comment:4 Changed 12 years ago by jserv@…

  • Cc jserv.tw@… added

comment:5 Changed 12 years ago by balrogg@…

  • Cc balrogg@… added

Changed 12 years ago by balrogg@…

Use struct gsmd_port instead of fd's.

Changed 12 years ago by balrogg@…

TS 07.10 multiplexing (incomplete).

comment:6 Changed 12 years ago by cw@…

  • Cc cw@… added

comment:7 Changed 11 years ago by willie_chen@…

  • Owner changed from laforge@… to michael@…

comment:8 Changed 11 years ago by willie_chen@…

Hi Michael,

GSM TS07.10 multiplex is more important in GTA02. That will help you can make
phone call and make data transmission at the same time.

The multiplex can be in kernel mode or user mode (gsmd). Building multiplex in
kernel mode seems a heavy task.

comment:9 Changed 11 years ago by willie_chen@…

  • Owner changed from michael@… to sean_chiang@…
  • Component changed from kernel to gsmd

Small Sean will help this part. :-)

comment:10 Changed 11 years ago by sean_chiang@…

  • Status changed from new to assigned

comment:11 Changed 11 years ago by wally.ritchie@…

After doing some testing in user space with the calypso and not getting back any
replies on the list, i went ahead and rewrote a kernel mode mux from scratch. It
should be in shape very soon for a test release.

The initial release will be calypso only but it will support all (which is not
much) features of calypso. Eventually it will be extended to full support for
the standard. I've been reluctant to post too much further info until I have
working code but I will go ahead and post an outline to the gsm mailing list in
the next couple of days.

This is a kernel mode line discpline which supports any number of mux instances
and any number of virtual ports and can be configured on an individual mux
instance basis for TE side or MS side and protocol options.

comment:12 Changed 11 years ago by mickey@…

Wally.ritchie: thanks -- we are appreciating this and looking forward to the
release.

comment:13 Changed 11 years ago by mickey@…

  • Cc wally.ritchie@… added

Writchie, could you please give us an update on your achievements -- preferrably
an ETA for release? :)

comment:14 Changed 11 years ago by mickey@…

Writchie: ping?

comment:15 Changed 11 years ago by mickey@…

  • Status changed from assigned to closed
  • Resolution set to fixed

Writchie seems to be MIA. Meanwhile though, the freesmartphone project has
released a userspace MUXer with a nice dbus interface. Grab it at
http://www.freesmartphone.org/sources/.

comment:16 Changed 11 years ago by anonymous

  • Milestone Phase 0 deleted

Milestone Phase 0 deleted

Note: See TracTickets for help on using tickets.