Ticket #904 (closed defect: fixed)

Opened 12 years ago

Last modified 10 years ago

volume has poor range when headphones are plugged in.

Reported by: pavel@… Owned by: allen_chang
Priority: high Milestone:
Component: Audio Version: unspecified
Severity: normal Keywords: Neo1973 Hardware
Cc: buglog@… Blocked By:
Blocking: #1640 Estimated Completion (week):
HasPatchForReview: no PatchReviewResult:
Reproducible:

Description

I have volume set to 7% and it is still quite loud in headphones, while it is
pretty quiet on speaker. Changing volume makes audio stop for few second...

(I also get some funny effects whenever I touch the connector. Loud/ugly noise
and/or it switches back to speaker randomly. Sometimes I have headphones plugged
in and it still plays to speaker... but I guess that may be hw problem?)

Change History

comment:1 Changed 12 years ago by abraxa@…

  • Status changed from new to closed
  • Resolution set to invalid

I have volume set to 7% and it is still quite loud in headphones, while it is

pretty quiet on speaker.

To my regret that's not within the Player's scope - after all, the Media Player
isn't aware of which output is used (at least as of now).

Changing volume makes audio stop for few second...

That's a gstreamer/PulseAudio issue that was fixed in SVN already - it happens
because CPU load is way too high.

I also get some funny effects whenever I touch the connector.

That's outside the scope of the Media Player as well, so it might be a good
idea to file a separate bug report for that :)

-Soeren

comment:2 Changed 12 years ago by pavel@…

  • Status changed from closed to reopened
  • Component changed from openmoko-mediaplayer to Audio
  • product changed from OpenMoko to Neo1973 Hardware
  • Resolution invalid deleted
  • Keywords Neo1973 Hardware added; OpenMoko removed

Whenever I touch 2.5" connector, I hear really ugly stuff; sometimes music comes
from speaker even though headset is connected and it takes quite a lot of
fiddling to get headset to be detected and used. I guess that's hw problem?

comment:3 Changed 12 years ago by laforge@…

  • Owner changed from abraxa@… to tim_lee@…
  • Status changed from reopened to new

comment:4 Changed 11 years ago by tim_lee@…

  • Owner changed from tim_lee@… to allen_chang@…

comment:5 Changed 11 years ago by roh

  • Owner changed from allen_chang@… to allen_chang

comment:6 Changed 10 years ago by john_lee

  • Blocking 1640 added

comment:7 Changed 10 years ago by wendy_hung

  • Status changed from new to closed
  • HasPatchForReview unset
  • Resolution set to fixed

Please try with resent images, if it still happen the same then open another bug for specific case.

Note: See TracTickets for help on using tickets.