Ticket #909 (closed defect: fixed)

Opened 12 years ago

Last modified 11 years ago

After accepting PIN the dialer is not closed.

Reported by: emreturkay@… Owned by: thomas@…
Priority: high Milestone:
Component: openmoko-dialer Version: 2007.2
Severity: normal Keywords:
Cc: buglog@…, kresp0@…, Tuukka.Hastrup@… Blocked By:
Blocking: Estimated Completion (week):
HasPatchForReview: PatchReviewResult:
Reproducible:

Description


Change History

comment:1 Changed 12 years ago by thomas@…

Please describe your problem in more detail.

comment:2 Changed 12 years ago by Tuukka.Hastrup@…

I think what's expected here with respect to the PIN entry functionality is the
beginnings of at least the following behaviour:

  1. While entering a PIN, show dots instead of the actual PIN numbers.
  1. After the PIN has been sent, clear the entry field.
  1. If the PIN is incorrect, prompt again.
  1. If the PIN is correct, show a notification message that the PIN was accepted.
  1. If the PIN is correct and the user didn't ask the dialer to come up, close

the dialer.

  1. If an emergency number is entered instead, it should be shown as digits and

the dial button should be available.

comment:3 Changed 12 years ago by Tuukka.Hastrup@…

  • Cc Tuukka.Hastrup@… added

comment:4 Changed 12 years ago by kresp0@…

  • Cc kresp0@… added

comment:5 Changed 11 years ago by mickey@…

I agree. Especially point 5 is important here. If the dialer only came up
because of a PIN request, it is safe to assume that the user doesn't want to
dial immediately afterwards, so let's hide it.

comment:6 Changed 11 years ago by thomas@…

  • Status changed from new to assigned

comment:7 Changed 11 years ago by thomas@…

  • Status changed from assigned to closed
  • Resolution set to fixed

This is now fixed in SVN.

Note: See TracTickets for help on using tickets.